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SmartFusion2, IGLOO2, and RTG4 Block Flow
Block Flow is a bottom-up design methodology that enables you to use design blocks (“components” in
generic terms) as building blocks for your top-level design. These building blocks may have already
completed layout and been optimized for timing and power performance for a specific Microsemi device.
Using these blocks as part of your top-level design can cut down design time as well as improve timing and
power performance. Block advantages include:
•

Focus on the timing of critical blocks and ensure the timing across the blocks meets requirements
before proceeding to integrate your blocks at the top level.

•

Changes in other blocks have no impact on your own block; you can re-use your block without reoptimizing for timing closure.

•

The block can be re-used in multiple designs.

•

Shorter verification time; you need to re-verify only the portion of the design that has changed.

•

A Block can be synthesized, simulated, and placed-and-routed the same way as a regular design.

Block Features
•

You can lock the placement and routing of the Block to ensure repeatable performance.

•

Performance, placement and routing can be fixed absolutely; however these rules can be relaxed
gradually, if necessary, to ensure that you can integrate the Block into your top level project.

Use blocks when:
•

You have multiple team members working on different parts of the same design.

•

The design is congested (uses 90% or more of the resources on a given die).

•

You have difficulty meeting timing by doing the design in its entirety. Blocks enable you to
compartmentalize the design and optimize sections before you optimize the entire design.

•

You want to re-use some elements of your design.

•

You want to use the identical elements multiple times in a single design.

•

You want to make small changes in your design and expect to keep most of the design unchanged
with guaranteed performance.

You cannot use Blocks with all families, they are family and die specific; if your Block has I/Os it is also
package specific.

HDL Supported
•

Verilog

•

VHDL

Synthesis Tools Supported
•

Synplify Pro

Nested Blocks
Nested blocks (blocks instantiated inside other blocks) are supported. When publishing, only one file will be
published that contains all the required information (including the nested block).

Creating Blocks - Options and Settings
To enable Block Creation for a new project, from the Project menu, choose New Project. Check the Enable
Block Creation checkbox. Select the Enhanced Constraint Flow for the new project.
In an existing project, from the Project menu, choose Project Settings. Click Design Flow and check the
Enable Block Creation checkbox. The existing project must be using the Enhanced Constraint Flow.
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Synthesis Tool Settings
In Synplify Pro, the I/O Insertion option is disabled when the block is synthesized. Libero automatically
disables I/O insertion for you before invoking Synplify Pro.

Synthesis
During Synthesis, Libero SoC software adds BLOCK_INTERFACE_I* instances to the block. These
instances are virtual buffers added to:
•

Improve timing values for the block.

•

Provide you with a clear interface to floorplan

•

Help with clustering constraints

The BLOCK_INTERFACE_I* instances are removed when the block is published.

Figure 1 · Creating and Publishing Design Blocks

Publish Options/Settings
Use the Publish Block – Configuration Options dialog box to configure the block for Publication.
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Publishing Blocks After Synthesis or Layout
You can publish your block after Synthesis or Layout.

Publish After Synthesis
If you publish a block after Synthesis but before Layout, a netlist is exported for the block when published.
No Place and Route information or Region Constraint information is included in the block when published. A
Warning message appears when you publish a block before Place and Route.

Publish After Layout
If you publish a block after Layout, the Placement, Routing and/or Region Constraint information will be
published along with the netlist. You can always open the configurator and change the options to publish
what you want. All macros must be locked or assigned to regions in order to publish the Placement
information.

Published Content
Libero exports the <design>.cxz file to <project folder>/designer/<design_block_name>/export folder when a
block is published. The <design>.cxz file is a zip file that contains the following files:
•

<design_block_name>_syn.v | <design_block_name>_syn.vhd -- A timing shell file passed to
synthesis tools when the top-level design is synthesized. The block is marked and treated as a black
box when the top-level design is synthesized.

•

<design_block_name>_sim.v | <design_block_name>_sim.vhd -- A structural HDL netlist for
postsynthesis simulation of the block.

•

header_report.log - A log file that contains Header Information on what and how a block is published ,
including the options you selected to configure the publication.

•

<design_block_name>_compile_netlist_resources.xml -- Compile Report detailing resource usage,
device info, and a list of high-fanout nets.

•

<design_block_name>_gp_report.xml -- Global Placement and Routing Report

•

<design_block_name>_compile_netlist_combinational_loops.xml -- Combinational Loops Report

•

<design>.cdb – Internal proprietary file containing the optimized netlist , placement, routing or timing
constraint information

•

<design_block_name>.sdc - contains the SDC constraints for the block to be used for Timing
Verifications.

The <design_block_name>.cxz file is your published block. You can move it to another folder, transfer it to
other team members, etc. This is the file you import into your top-level design when you want to instantiate
the block.

Guidelines for Creating Blocks
Macros/IPs Not Supported in Blocks
When creating a Block for instantiation in a top-level design, please note that the following types of macros
are not allowed: MSS, SERDESIF, FDDR, FLASH_FREEZE, SYSRESET, UJTAG.

Synthesis Tool and Globals Management
The synthesis tool may promote all clocks to globals. Keep in mind the number of globals you need in your
top level design and the number of globals allowed in the device (8 or 16 depending on device size) you are
targeting. You may need to reduce or limit the number of globals in your block by adding row globals or plan
to share globals in the top-level design with the block. To add a row global, you can add it directly to your
HDL (RCLKINT).
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Blocks and DRC
Regular DRC rules are applied to blocks as in the regular Libero design flow. For example, some DRC rules
assume that some pins must be connected to the power nets. These rules are enforced on the blocks in the
block flow just as in the regular design flow.

Blocks and Floorplanning
When creating a block, floorplanning is essential if you plan to publish placement information. Before
running Layout on the block, you must floorplan the design block. You can use Chip Planner or PDC
commands for floorplanning.
If you do not create a region and constrain the Block to the region (floorplanning ) or lock the macros before
place and route, a Warning message appears when you publish the Block. It warns you that not all macros
in the Block have been constrained to regions or locked and therefore only your design netlist is exported
when the Block is published.

Floorplanning with PDC Commands
You can use the define_region PDC command to create a rectangular or rectilinear region, and then use the
assign_region PDC command to constrain all the macros to that region. Refer to the Libero Help for the
command syntax.
Floorplanning reduces the risk of placement conflicts of the blocks at the top level.
If you do not constrain your Block placement, its components may be placed anywhere on the die.
It is also important to consider the placement of all Block Interface Instances at the boundaries of Block
regions. This facilitates the interconnection of the Block to the top-level design. If the Block is highly
optimized (densely packed) there may be no routing channels available to connect to any internal Block
Interface Instances. Placing all interfaces at Block boundaries helps you eliminate routing congestion and
failure.

Floorplanning with Chip Planner
Refer to Chapter 4 of Chip Planner for details on how to use the Chip Planner for floorplanning.

Architecture Limitations - Managing Blocks and Globals
Architecturally, the silicon has 8 or 16 globals per device, depending on the device size. If you create a block
for use in a top level design and you know that the top level design will use close to the maximum number of
Globals for the device, it is good practice to minimize the number of Globals when you create the block.
Examine the Global Report to see how many Globals have been used for the block. To reduce the number
of Globals used in the block, you may consider clock sharing and the use of Row Globals for the block.
To add an internal global on a port, you can use either the Synplify constraints editor (SCOPE) or an SDC
file.
For example, to add a CLKINT after a CLK port, the command is:
define_attribute {n:CLK} syn_insert_buffer {CLKINT}

Instantiating Blocks in your Top-Level Design
You may instantiate multiple instances of the same block or multiple blocks in the top-level design.
Microsemi recommends that you create a new project for your top-level design. To do so:
1.
2.
3.
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From the Project menu choose New Project.
Deselect the Enable Designer Block Creation checkbox.
Choose the Family/Die/Package for the new project for the top-level as follows :

•

If the block is a Netlist only and was not published with place and route information, choose the same
Family as the block for the new project. Choose any Die and Package.

•

If the block contains placement information, choose the same Family and Die as the block for the new
project, and choose any Package.
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•
4.

If the Netlist contains I/O and Placement Information, choose the same Family, Die and Package as
the block for the new project.
Choose the Enhanced Constraint Flow for the top level design project.

Note: A top level project created for the Enhanced Constraint Flow can only import and instantiate blocks
created and published from an Enhanced Constraint Flow project. It cannot import nor instantiate
blocks published from the Classic Constraint Flow project. Likewise, a top level project created for the
Classic Constraint Flow cannot import nor instantiate blocks created and published from an
Enhanced Constraint Flow project.

Import the Block
1.
2.
3.

From the File menu choose Import > Blocks.
Browse to the directory that contains your <design_block_name>.cxz file and select it.
Click Open.

<design_block_name> is imported into the top_level project. Version control is not supported for imported
blocks. If you import the same block twice, the existing block is overwritten by the new one.
The files will be imported under <design>\component\work\<design_block_name>.
Review the files in the above directory to view Block Reports.
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Create a Top Level Design that Uses Blocks
Use SmartDesign or HDL to create your top level design. If you use HDL you can create HDL for the top
level or import a top-level HDL file.

Figure 2 · Instantiating Blocks in your Top Level Design

Constraints Management
When a block with PDC constraints are imported into the top level design, the block’s PDC constraints are
captured and stored in two files:

10

SmartFusion2, IGLOO2, and RTG4 Designing with Blocks in the Enhanced Constraint Flow
•

<top_level_module>.block.io.pdc for the IO PDC constraints

•

<top_level_module>.block.fp.pdc for the floorplanning PDC constraints.

The <top_level_module>.block.io.pdc is displayed in the I/O Attributes tab of the Constraint Manager on top
of any other IO PDC files.
The <top_level_module>.block.fp.pdc is displayed in the Floor Planning tab of the Constraint Manager on
top of any other floorplanning PDC files.
Note: Do not modify these block PDC files at the top level. If these PDC files need to be modified, go back to the
project where the blocks are created and published. Make the floorplanning modifications and publish the block. Reimport the block into the top level. You may need to remove any duplicate blocks, if any, at the top level after the reimport.

Hierarchical Structure Resolution in Top Level Projects
If you import multiple conflicting definitions for your *.v files, Libero resolves the conflicts as shown below.

Duplicate Block Definition
If you import two versions of your block file you must choose which one you want to use. For example:
1.
2.

Import top.v and block1.v files as HDL (File > Import HDL Source Files) into the top level project.
Import <block1> (File > Import > Blocks).

Libero recognizes a duplicate definition of <block1>; one from the HDL and another in the imported block
file. The Design Hierarchy tab shows a <block1>.cxf and <block1>.v file under Duplicate Modules; Libero
uses the HDL <block1> by default.
To override the default behavior and select the Block definition, right-click the <block1>.cxf file and choose
Use This File. When you update the behavior the Block icon appears in the Design Hierarchy.

Conflicting Definitions in top.v and Your Imported Block File
You can introduce a conflict if you import a top.v file and a block file. Libero does not support HDL definition
of low level blocks inside top level HDL files and subsequent importing of block files. For example, the
following will cause an error:
1.
2.

Import a top.v file (File > Import HDL Source Files) that contains a definition for <top> and a module
definition for <block1>.
Import the block <block1> (File > Import > Blocks).

Libero passes two duplicate files to your synthesis tool because the definition for <block1> is duplicated. To
continue, you must remove the definition of <block1> from top.v and then re-import it.

Resolving top.v and Block Instantiations
Libero integrates your top.v file and block file if there is no definition for the block file in top.v. For example:
1.
2.

Import your top.v (File > Import HDL Sources Files) that contains instantiations but no definition of
<block1>.
Import <block1> (File > Import> Blocks).

Libero resolves the hierarchy for you and puts <block1> under top.v.

EDIF Netlist in the Top Level Design
If the Top Level design is in EDIF, you must convert the EDIF to HDL and then import the HDL into Libero.
To convert the Top Level EDIF to HDL:
1.

Write a Tcl script. For example:

set_device -fam SmartFusion2
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read_edif -file {E:\top.edn}
write_verilog -file {E:\top.v} –skip_empty_modules 1
write_vhdl -file {E:\top.vhd}
## -skip_empty_modules 1 is to instruct the tool not to insert module ## definition for
the empty modules in the HDL created.

2.

From the Windows Command Prompt or the Linux shell, run rwnetlist as follows (this executable is
located in the same location as Libero):

rwnetlist --script "E:/run_export_netlist.tcl”

Synthesis
Libero passes the block timing to your synthesis tool when the top level is synthesized. This timing shell
enables the synthesis tool to produce more accurate timing numbers for top level synthesis.
The timing shell also instructs the synthesis tool to treat the design block as a black box; this is done
automatically - no action is required.
Use the Synthesis tool options (Design Flow > Synthesize > Configure Options) for "Resolving Place and
Route Conflicts" on page 12 of blocks.

Resolving Place and Route Conflicts
To resolve Place and Route conflicts at the top-level:
•

Examine the <design_block_name>_compile_netlist_resources.xml Report. Identify the cause of the
problem and manually place and constrain the placement with Chip Planner or with PDC commands.

•

If you instantiate a block (published with placement) multiple times then placement between multiple
block instances will overlap. To remove overlapping, move the block placement of one or more
instances to another area using the PDC command move_block. Put the move_block command inside
the NDC file and associate the NDC file with Synthesis (Constraint Manager> Netlist Attributes)

•

The software enforces Global sharing. If there is a Global driving a CLKINT in the block it will be
deleted. Reduce the number of Globals at the top level by sharing Global Clock resources. Globals in
the Blocks may also be re-routed (not preserved).

Synthesis Options to Resolve Place and Route Conflicts
If there are multiple blocks instantiated in your top level design, the software uses the Synthesis Options to
resolve the conflicts. These options appear only if there are blocks in your design. Use the synthesis options
(Design Flow > Synthesize > Configure Options) to resolve Placement and/or Routing conflicts.

Placement
Error if conflict - The Layout tool errors out if any instance from a designer block is unplaced. This is the
default option.
Resolve conflict
•

Keep non-conflicting placement - If some instances get unplaced for any reason, the non-conflicting
elements remaining are preserved but not locked (you can move them).

•

Keep and lock non-conflicting placement - If some instances get unplaced for any reason, the
remaining non-conflicting elements are preserved and locked.

•

Discard placement from all blocks – Placement information will be discarded from all blocks even if there is
no conflict.

Routing
Error if conflict - The Layout tool errors out if any preserved net routing in a designer block is deleted.
Resolve conflict
•
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Keep non-conflicting routing- If a nets' routing is removed for any reason, the routing for the nonconflicting nets is preserved but not locked (so that they can be rerouted). This is the default option.
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•

Keep and lock non-conflicting routing- If the routing is removed for any reason, the remaining nonconflicting nets are preserved and locked; they cannot be rerouted. This is the default option.

•

Discard routing from all blocks – Routing information will be discarded from all blocks even if there
is no conflict.

Figure 3 · Synthesis Options Dialog Box

Block PDC Commands
move_block and set_block_options are two PDC commands available specifically for working with design
blocks at the top level.
Use the move_block and set_block_options commands to make changes in your Top-Level design. See the
respective help topics for more information.
In the top level design, put the move_block and set_block_options commands in an NDC file (Design Flow
Window > Manage Constraints > Open Manage Constraints View > Netlist Attributes > New > Create
New Compile Netlist Constraints NDC) and associate the NDC file with Synthesis.
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move_block
PDC command; moves a design block from its original, locked placement by preserving the relative
placement between the instances. You can move the Block to the left, right, up, or down.
Note: If possible, routing is preserved when you move the blocks for IGLOO, SmartFusion, Fusion and
ProASCI3 families.
move_block -inst_name instance_name -up y -down y

-left x -right x

-non_logic value

Arguments
-inst_name instance_name

Specifies the name of the instance to move. If you do not know the name of the instance, run a Compile
report or look at the names shown in the Block tab of the Chip Planner.
-up y

Moves the block up the specified number of rows. The value must be a positive integer.
-down y

Moves the block down the specified number of rows. The value must be a positive integer.
-left x

Moves the block left the specified number of columns. The value must be a positive integer.
-right x

Moves the block right the specified number of columns. The value must be a positive integer.
-non_logic value

Specifies what to do with the non-logic part of the block, if one exists. The following table shows the
acceptable values for this argument:
Value

Description

move

Move the entire block.

keep

Move only the logic portion of the block (COMB/SEQ) and keep the rest
locked in the same previous location, if there is no conflict with other
blocks.

unplace

Move only the logic portion of the block (COMB/SEQ) and unplace the rest
of it, such as I/Os and RAM.

Supported Families
SmartFusion2, IGLOO2, RTG4, SmartFusion, IGLOO, ProASIC3, Fusion

Description
This command moves a block from its original, locked position to a new position.
You can move the entire block or just the logic part of it. You must use the -non_logic argument to specify
what to do with the non-logic part of the block. You can find placement information about the block in the
Block report. From the Tools menu in the designer software, choose Reports > Block > Interface to
display the report that shows the location of the blocks.
The -up, -down, -left, and -right arguments enable you to specify how to move the block from its original
placement. You cannot rotate the block, but the relative placement of macros within the block will be
preserved and the placement will be locked. However, routing will be lost. You can either use the
ChipPlanner tool or run a Block report to determine the location of the block.
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The -non_logic argument enables you to move a block that includes non-logic instances, such as RAM or
I/Os that are difficult to move. Once you have moved a part of a block, you can unplace the remaining
parts of the block and then place them manually as necessary.
Note: Note: Microsemi recommends that you move the block left or right by increments of 12. If not,
placement may fail because it violates clustering constraints. Also, Microsemi recommends that
you move the block up or down by increments of three.

Exceptions
•

You must import this PDC command as a source file, not as an auxiliary file.

•

You must use this PDC command if you want to preserve the relative placement and routing (if
possible) of a block you are instantiating many times in your design. Only one instance will be
preserved by default. To preserve other instances, you must move them using this command.

Examples
The following example moves the entire block (instance name instA) 12 columns to the right and 3 rows up::
move_block -inst_name instA -right 12 -up 3 -non_logic move

The following example moves only the logic portion of the block and unplaces the rest by 24 columns to the
right and 6 rows up.
move_block -inst_name instA –right 24 –up 6 –non_logic unplace

See Also
set_block_options
PDC Reference
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set_block_options
PDC command; overrides the compile option for placement or routing conflicts for an instance of a block.
set_block_options -inst_name instance_name -placement_conflicts value -routing_conflicts
value

Arguments
-inst_name instance_name

Specifies the block instance name. If you do not know the name of the instance, run a Block Report
(Design > Reports > Blocks > Interface) or look at the names shown in the Block tab of the Chip
Planner.
-placement_conflicts value.

Specifies what to do when the software encounters a placement conflict. The following table shows the
acceptable values for this argument:
Value

Description

error

Compile errors out if any instance from a Designer block becomes unplaced
or its routing is deleted. This is the default compile option.

resolve

If some instances get unplaced for any reason, the non-conflicting elements
remaining are also unplaced. Basically, if there are any conflicts, nothing
from the block is kept.

keep

If some instances get unplaced for any reason, the non-conflicting elements
remaining are preserved but not locked. Therefore, the placer can move
them into another location if necessary.

lock

If some instances get unplaced for any reason, the non-conflicting elements
remaining are preserved and locked.

discard

Discards any placement from the block, even if there are no conflicts.

-routing_conflicts value

Specifies what to do when the software encounters a routing conflict. The following table shows the
acceptable values for this argument:
Value
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Description

error

Compile errors out if any route in any preserved net from a Designer block is
deleted.

resolve

If a route is removed from a net for any reason, the routing for the nonconflicting nets is also deleted. Basically, if there are any conflicts, no routes
from the block are kept.

keep

If a route is removed from a net for any reason, the routing for the nonconflicting nets is kept unlocked. Therefore, the router can re-route these
nets.

lock

If routing is removed from a net for any reason, the routing for the nonconflicting nets is kept as locked, and the router will not change them. This
is the default compile option.
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Value
discard

Description
Discards any routing from the block, even if there are no conflicts.

Supported Families
SmartFusion2, IGLOO2, RTG4, SmartFusion, IGLOO, ProASIC3, Fusion

Description
This command enables you to override the compile option for placement or routing conflicts for an
instance of a block.

Exceptions
You must import this PDC command as a source file, not as an auxiliary file.
If placement is discarded, the routing is automatically discarded too.

Examples
This example makes the designer software display an error if any instance from a block becomes unplaced
or the routing is deleted:
set_block_options -inst_name instA -placement_conflicts ERROR -routing_conflicts ERROR

See Also
move_block
PDC Reference

Publish Block - Configuration Options
To view this dialog box you must first Enable Block Creation in the Libero SoC Project Settings or New
Project Creation Wizard. After Block Creation is enabled Publish Block appears in the Design Flow window.
Expand Publish Design, right-click Publish Block and choose Export.

Publish Block Configuration
Publish Placement- Check this box to publish the placement information for the Block. Note that you must
assign all macros to regions or lock them in order to Publish Placement.
If checked, the published Block can only be instantiated and used in a top level design with the same family
and device. If the Block contains I/Os, the published Block can only be instantiated and used in a top level
design with the same family, device and package.
If unchecked, only a netlist is published for the block. The published block can be instantiated and used in a
top level design for any device and package in the same device family as the block.
Publish Routing - Check this box to retain the routing information with the block when published.
Publish Region - Check this box to retain the region constraint information with the block when published.

Language
Select your Block Hardware Description Language (Verilog or VHDL). The default is the Preferred HDL type
set in your Project Settings.
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