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Introduction  (Ask a Question)

SmartTime is a Libero® SoC interactive gate-level static timing analysis tool that allows you to visualize and
identify timing issues in your designs. Using this tool, you can evaluate how close you are to meeting your
timing requirements, create custom sets to track, set timing exceptions to obtain timing closure, and define
cross-probe paths with other tools. Key SmartTime features allow you to:

• Perform complete timing analysis of your design to ensure that your designs meet all timing constraints and
operate at the desired speed, with the appropriate amount of margin across all operating conditions.

• Browse through your design’s various clock domains to examine the timing paths and identify those that
violate your timing requirements.

• Create customizable timing reports.
• Navigate directly to the paths responsible for violating your timing requirements.

Note: Creating and editing timing constraints are handled in a separate Timing Constraints Editor. For more
information, see the Timing Constraints Editor User Guide.

Supported Device Families
The following table lists the family of devices that Libero SoC supports. This guide covers all these device
families. However, some information in this guide might apply to certain device families only. In this case, such
information is clearly identified.

Table 1. Device Families Supported by Libero®  SoC
Device Family Description

PolarFire® PolarFire FPGAs deliver the industry’s lowest power at mid-range densities with exceptional security and reliability.

PolarFire SoC PolarFire SoC is the first SoC FPGA with a deterministic, coherent RISC-V® CPU cluster, and a deterministic L2
memory subsystem enabling Linux® and real-time applications.

SmartFusion® 2 SmartFusion 2 addresses fundamental requirements for advanced security, high reliability, and low power in critical
industrial, military, aviation, communications, and medical applications.

IGLOO® 2 IGLOO 2 is a low-power mixed-signal programmable solution.

RTG4™ RTG4 is Microchip's family of radiation-tolerant FPGAs.

Important: This document is updated frequently. The latest version of this document is
available at this location: Libero SoC Design Suite Documentation.
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1. About SmartTime  (Ask a Question)

The following sections describe SmartTime functions.

1.1. Static Timing Analysis (STA)  (Ask a Question)

Static Timing Analysis (STA) offers an efficient technique for identifying timing violations in your
design and ensuring that it meets all your timing requirements. You can communicate timing
requirements and timing exceptions to the system by setting timing constraints. Then a static
timing analysis tool checks and reports setup, and holds violations and violations on specific path
requirements.

STA is particularly well suited for traditional synchronous designs. The main advantage of STA is that
unlike dynamic simulation, it does not require input vectors. It covers all possible paths in the design
and does all the above with relatively low run-time requirements.

A major disadvantage of STA is that the STA tools do not automatically detect false paths in their
algorithms as it reports all possible paths, including false paths, in the design. False paths are
timing paths in the design that do not propagate a signal. To get a true and useful timing analysis,
identify any false paths as false path constraints to the STA tool and exclude them from timing
considerations.

The SmartTime user interface provides efficient, user-friendly ways to define these critical false
paths.

1.2. Timing Constraints  (Ask a Question)

SmartTime supports a range of timing constraints to provide useful analysis and efficient timing-
driven layout.

1.3. Timing Analysis  (Ask a Question)

SmartTime provides a selection of analysis types that allow you to:

• Find the minimum clock period/highest frequency that does not result in a timing violations
• Identify paths with timing violations
• Analyze delays of paths that have no timing constraints
• Perform inter-clock domain timing verification
• Perform maximum and minimum delay analysis for setup and hold checks

To improve the accuracy of the results, SmartTime evaluates clock skew during timing analysis by
computing individual clock insertion delays for each register.

SmartTime checks the timing requirements for violations while evaluating timing exceptions such as
multicycle or false paths.

1.4. SmartTime and Place and Route  (Ask a Question)

Libero SoC Place and Route uses SmartTime STA during timing-driven place-and-route operations
run in the background. As a result, your analysis and place and route constraints are always
consistent.

1.5. Timing Reports  (Ask a Question)

SmartTime provides robust reporting capabilities that allow you to generate the following report
files:

• Timing Report for Max and Min Delay Analysis
• Timing Violations Report for Max and Min Delay Analysis
• Bottleneck Report

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-8CA09B7E-0612-484F-81AC-C91F5F90F3EE&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=About%20SmartTime
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-BEAFAD70-2673-4F97-BEF0-DCFB9D24751F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Static%20Timing%20Analysis%20%28STA%29
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-9484D6A4-4B6D-4B14-9C78-48E405D90DCB&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Constraints
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1D6FE98E-382D-479E-A850-1BF1412EFC54&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Analysis
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4E0477DE-ADFD-421F-9199-76C96B988ADD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20and%20Place%20and%20Route
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1ECD6D56-B86B-4D55-9E6D-E9DE82F14FAD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Reports
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• Constraints Coverage Report
• Combinational Loop Report

1.6. Cross-probing into Chip Planner  (Ask a Question)

From SmartTime, you can select a design object and cross-probe the same design object in Chip
Planner.

Design objects that can be cross-probed from SmartTime to Chip Planner include:

• Ports
• Macros
• Timing paths

1.7. Cross-probing into Constraints Editor  (Ask a Question)

From SmartTime, you can cross-probe into the Constraints Editor. The Constraints Editor must be
running for cross-probing to work.

For more information, see section Cross-Probing from SmartTime to Chip Planner.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-FB9D5415-E90A-4CF7-8620-11ED2BEC8CF5&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Cross-probing%20into%20Chip%20Planner
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-66C5BB5B-CAE2-4739-9251-F48825493292&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Cross-probing%20into%20Constraints%20Editor
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2. Design Flows with SmartTime  (Ask a Question)

You can access SmartTime in Libero SoC during the following design implementation phases:

• During Place and Route—when you select timing-driven place-and-route, SmartTime runs in the
background to provide accurate timing information.

• After Place and Route—run SmartTime to perform post-layout timing analysis and adjust timing
constraints. In the Libero SoC Design Flow window, expand Implement Design > Verify Post-
Layout Implementation and then either:

– Double-click Verify Timing to generate Timing Reports.
– Right-click Open SmartTime > Open Interactively to run SmartTime.

• During Back-Annotation—SmartTime runs in the background to generate the SDF file for timing
simulation.

You can also run SmartTime to generate Timing Reports, regardless of which design implementation
phase you are in.

For more information about Place and Route and Back-Annotation, see the Libero SoC Design Flow
User Guide.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-19433C68-C188-4952-B4CB-C85384DB239C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Design%20Flows%20with%20SmartTime
http://coredocs.s3.amazonaws.com/Libero/2025_1/Tool/libero_ecf_ug.pdf
http://coredocs.s3.amazonaws.com/Libero/2025_1/Tool/libero_ecf_ug.pdf
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3. Starting and Closing SmartTime  (Ask a Question)

You must complete Place and Route for your design before using SmartTime interactively.
Otherwise, Libero SoC completes that phase before starting SmartTime.

To open SmartTime interactively:

1. Select Implement Design > Verify Post Layout Implementation.
2. Right-click Open SmartTime and select Open Interactively.

SmartTime reads your design and displays post- or pre-layout timing information.
To close SmartTime, choose Exit from the File menu.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E9AC2CD2-CDE5-47F1-AC42-BD038D739884&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Starting%20and%20Closing%20SmartTime
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4. Configuring SmartTime Settings  (Ask a Question)

The SmartTime Options dialog box allows you to change general, analysis, and advanced settings.

4.1. Configuring SmartTime General Settings  (Ask a Question)

To configure General settings in the SmartTime Options dialog box:

1. From the SmartTime Maximum/Minimum Delay Analysis View window, choose Tools > Options.
The SmartTime Options dialog box appears.

Figure 4-1. SmartTime Options Dialog Box—General Settings for SmartFusion®  2, IGLOO®  2, and RTG4™

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-57260E9F-ECFE-4CD4-9174-73B0F5B6B30E&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Configuring%20SmartTime%20Settings
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-2BC49441-8A26-45B9-AB98-4BCCB93652AA&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Configuring%20SmartTime%20General%20Settings
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Figure 4-2. SmartTime Options Dialog Box—General Settings for PolarFire®

2. In the General category, select the settings for the operating conditions. SmartTime performs
maximum or minimum delay analysis based on the best, typical, or worst case.

3. Specify whether you want SmartTime to use inter-clock domains in calculations for timing
analysis.

4. To revert the General settings to their default value, click Restore Defaults.
5. Change Analysis and Advanced settings as necessary.
6. When finished, click OK.

4.2. Configuring SmartTime Analysis Settings  (Ask a Question)

To configure Analysis settings in the SmartTime Options dialog box:

1. From the SmartTime Maximum/Minimum Delay Analysis View window, choose Tools > Options.
The SmartTime Options dialog box appears.

2. In the left pane, click Analysis.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F8EBF1C6-7B33-4933-8962-339CDD10130F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Configuring%20SmartTime%20Analysis%20Settings


 Libero SoC v2025.2
Configuring SmartTime Settings

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 10

Figure 4-3. SmartTime Options Dialog Box—Analysis Settings

3. Enter a number greater than 1 to specify the maximum number of paths to include in a path set
during timing analysis.

4. Check or uncheck whether to filter the paths by slack value. If you check this box, specify the
slack range between the minimum slack and maximum slack.

5. Check or uncheck whether to include clock network details.
6. To specify the number of parallel paths in the expanded path, enter a number greater than 1.
7. To revert the Analysis settings to their default value, click Restore Defaults.
8. Change General and Advanced settings as necessary.
9. When finished, click OK.

4.3. Configuring SmartTime Advanced Settings  (Ask a Question)

To configure Advanced settings in the SmartTime Options dialog box:

1. From the SmartTime Maximum/Minimum Delay Analysis View window, choose Tools > Options.
The SmartTime Options dialog box appears.

2. In the left pane, click Advanced.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-87D093CA-640D-4AE0-ACF2-156E3571B6C5&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Configuring%20SmartTime%20Advanced%20Settings
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Figure 4-4. SmartTime Options Dialog Box—Advanced Settings

3. Specify whether to use loopback in bidirectional buffers (bibufs) and/or break paths at
asynchronous pins. Then specify whether to disable non-unate arcs in the clockpath.

4. To revert the Advanced settings to their default value, click Restore Defaults.
5. Change General and Analysis settings as necessary.
6. When finished, click OK.
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5. SmartTime Toolbar  (Ask a Question)

The SmartTime toolbar contains icons for constraining or analyzing designs. Tool tips are available
for each icon.

Table 5-1. SmartTime Toolbar Icons
Icon Description

Saves the changes.

Undoes previous changes.

Redoes previous changes.

Opens the maximum delay analysis view.

Opens the minimum delay analysis view.

Opens the manage clock domains manager.

Opens the path set manager.

Recalculates all analyses.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D2917F1D-978D-40B7-961F-80C39B0DC983&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20Toolbar
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6. SmartTime Timing Analyzer  (Ask a Question)

The following sections describe the SmartTime Timing Analyzer functions.

6.1. SmartTime Analyzer Components  (Ask a Question)

SmartTime Timing Analyzer consists of the following components:

• Domain Browser: Alows you to perform your timing analysis on a per domain basis.
• Path List: Shows paths in a specific set within a given domain sorted by slack.
• Path Details: Shows detailed timing analysis of a selected path in the paths list.
• Analysis View Filter: Allows you to filter the content of the paths list.
• Path Slack Histogram: When a set is selected in the Domain Browser, Path Slack Histogram shows

a distribution of the path slacks for that set. Selecting one or multiple bars in the Path Slack
Histogram filters the paths shown in the Path List.

The following figure shows the SmartTime Timing Analyzer Components. You can copy and change
the resolution and number of bars of the chart from the right-click menu.

Figure 6-1. SmartTime Timing Analyzer Components

6.2. Analyzing Your Design  (Ask a Question)

The timing engine uses the following priorities when analyzing paths and calculating slack:

1. False path
2. Max/Min delay
3. Multi-cycle path
4. Clock

If multiple constraints of the same priority apply to a path, the timing engine uses the tightest
constraint.

You can perform two types of timing analysis:

• Maximum Delay Analysis

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-ACBC75AF-8281-4EC9-8923-D807DC7097AB&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20Timing%20Analyzer
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-5F85DF7E-3E12-4D74-BF78-1557FACD1197&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20Analyzer%20Components
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F4A6FB88-4321-49A4-8B94-DD48F15DF809&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Analyzing%20Your%20Design
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• Minimum Delay Analysis

To perform the basic timing analysis, use one of the following methods to open the Timing Analysis
View:
• From the SmartTime Tools menu, choose Timing Maximum Delay Analysis or Minimum Delay

Analysis.

• From the SmartTime window, click the  icon for Maximum Delay Analysis or the  icon for
Minimum Delay Analysis.

Note: When you open the Timing Analyzer from Designer, the Maximum Delay Analysis window
appears by default.

6.3. Maximum Delay Analysis View  (Ask a Question)

To enter Maximum Delay Analysis View:

1. In the Domain Browser, select the clock domain. Clock domains with a  indicate that the
timing requirements in these domains were met. Clock domains with an x indicate that there
are violations within these domains. Paths List shows the timing paths sorted by slack. The path
with the lowest slack (biggest violation) is at the top of the list.

2. Select the path you want to view.
Path Details below the Paths List shows detailed information about how the slack was
computed by detailing the arrival time and required time calculation. If a path is violated, the
slack is negative and shown in red.

3. To display a separate view that includes the path details and schematic, double-click the path.
4. Repeat this procedure as necessary.

Note: If the minimum pulse width of one element on the critical path limits the maximum
frequency for the clock, an icon for the clock name appears in the Summary List. Clicking the
icon displays the name of the pin that limits the clock frequency.

6.4. Managing Clock Domains  (Ask a Question)

In SmartTime, timing paths are organized by clock domains.

By default, SmartTime displays domains with explicit clocks. Each clock domain includes at least
three path sets:
• Register to Register
• External Setup (in the Maximum Analysis View) or External Hold (in the Minimum Analysis View)
• Clock to Out

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F88A01EE-5AB5-4D94-AC5B-CB7720BF745F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Maximum%20Delay%20Analysis%20View
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-8A8F1347-1EB0-413C-A72C-3D3023EF077A&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Managing%20Clock%20Domains
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You must select a path set to display a list of paths in that specific set.

To manage the clock domains:

1. Right-click anywhere in the Domain Browser and choose Manage Clock Domains.
The Manage Clock Domains dialog box appears.

Tip: You can click the  icon in the SmartTime window bar to display the
Manage Clock Domains dialog box.

2. To add a new domain, select a clock domain from the Available clock domains list and click
Add. To add a non-explicit clock domain, click New Clock.
The Choose the Clock Source Pin dialog box appears, and you can select the clock source pin.
You can choose to filter the available pins and search.

Figure 6-2. Choose the Clock Source Pin Dialog Box

3. To remove a displayed domain, select a clock domain from the Show the clock domains in this
order list and click Remove.

4. To change the display order in the Domain Browser, select a clock domain from the Show the
clock domains in this order list, and then use Move Up or Move Down to change the order in
the list.

5. Click OK.
SmartTime updates the Domain Browser based on your specifications. If you added a new clock
domain, it includes at least three path sets, as mentioned in the preceding step.
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6.5. Managing Path Sets  (Ask a Question)

You can create and manage custom path sets for timing analysis and tracking purposes.

Path sets appear below Custom Path Sets at the bottom of the Domain Browser.
To manage path sets:

1. Right-click anywhere in the Domain Browser and choose Add Set.
The Add Path Analysis Set dialog box appears.

Tip: You can click the  icon in the SmartTime window bar to display the
Add Path Analysis Set dialog box.

Figure 6-3. Add Path Analysis Set Dialog Box

2. Enter a name for the path set.
3. Select the source and sink pins. You can use the Using Filters to control the type of pins

displayed.
4. Click OK.

The new path set appears below User Sets in the Domain Browser.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F0B11DE2-BDA2-43A1-A6DC-92BB221C7105&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Managing%20Path%20Sets
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Figure 6-4. Updated Domain Browser with User Sets

5. To rename a path:
a) Select the path set from User Sets in the Domain Browser.
b) Right-click the set you want to rename, and then choose Rename Set from the right click

menu.
c) Edit the name directly in the Domain Browser.

6. To remove a path:
a) Select the path set from User Sets in the Domain Browser.
b) Right-click the set you want to delete, and then choose Delete Set from the right click menu.

6.6. Displaying Path List Timing Information  (Ask a Question)

Path List in the Timing Analysis View shows the timing information required to verify the timing
requirements and identify violating paths. The Path List is organized in a grid where each row
represents a timing path with the corresponding timing information displayed in columns. Timing
information is customizable, allowing you to add or remove columns for each type of set.

By default, each type of set displays the following subset of columns:

• Register to Register: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, Setup, Minimum Period,
and Skew.

• External Setup: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, Setup, and External Setup.
• Clock to Out: Source Pin, Sink Pin, Delay, Slack, Arrival, Required, and Clock to Out.
• Input to Output: Source Pin, Sink Pin, Delay, and Slack.
• Custom Path Sets: Source Pin, Sink Pin, Delay, and Slack. You can add the following columns for

each type of set:
– Register to Register: Clock, Source Clock Edge, Destination Clock Edge, Logic Stage Count,

Max Fanout, Clock Constraint, Maximum Delay Constraint, and Multicycle Constraint.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-52DA0AB1-6D0D-457D-9B3F-3E9B44AA4BC0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Displaying%20Path%20List%20Timing%20Information
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– External Setup: Clock, Destination Clock Edge, Logic Stage Count, Max Fanout, Clock
Constraint, Input Delay Constraint, Required External Setup, Maximum Delay Constraint, and
Multicycle Constraint.

– Clock to Out: Clock, Source Clock Edge, Logic Stage Count, Max Fanout, Clock Constraint,
Output Delay Constraint, Required Maximum Clock to Out, Maximum Delay Constraint, and
Multicycle Constraint.

– Input to Output: Arrival, Required, Setup, Hold, Logic Stage Count, and Max Fanout.
– Custom Path Sets

To customize the set of timing information in the Path List:

1. Choose Customize table on the top-left corner of path list to open the Customize Paths List
Table dialog box.

Figure 6-5. Customize Paths List Table Dialog Box

2. To add one or more columns, select the fields to add from the Available fields list and click Add.
3. To remove one or more columns, select the fields to remove from the Show these fields in this

order list, and click Remove.
4. To change the order in which the fields appear, select fields in the Show these fields in this

order list and click Move Up or Move Down.
5. Click OK to add or remove the selected columns.

SmartTime updates the Timing Analysis View.

6.7. Displaying Expanded Path Timing Information  (Ask a Question)

SmartTime displays the list of paths and path details for all parallel paths.

The Path Details grid displays the path details for all parallel paths. The Path List displays all parallel
paths in your design.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-04C97206-E4B0-4F30-8562-90FE85060640&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Displaying%20Expanded%20Path%20Timing%20Information
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Figure 6-6. Path List View

To display the Expanded Path View:

1. From the Path List, double-click the path, or right-click a path and select expand selected paths.
2. From the Expanded Path View, double-click the path, or right-click the path and select expand

path.

Figure 6-7. Expanded Path View

The Expanded Path Summary provides a summary of all parallel paths for the selected path. The
Path Profile chart shows the percentage of time taken by cells and nets for the selected path. If
no parallel path is selected in this view, the Path Profile shows the percentage for all paths. By
default, SmartTime shows only one path for each Expanded Path. To change this default, use the
SmartTime Options dialog box.
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The Expanded Path View includes a schematic of the path and a path profile chart for the paths
selected in the Expanded Path Summary.

6.8. Using Filters  (Ask a Question)

You can use filters in SmartTime to limit the Path List content (that is, create a filtered list on the
source and sink pin names).

Filtering options appear at the top of the Timing Analysis View. You can save these filters one level
below the set under which they have been created.

To use the filter:

1. Select a set in the Domain Browser to display a given number of paths, depending on your
SmartTime Options settings (100 paths by default).

2. Enter the filter criteria in both the From and To fields, and then click Apply Filter.
The display limits the paths to those that match your filter criteria.

Figure 6-8. Maximum Delay Analysis View

3. Click Store Filter to save your filter criteria with a special name.
The Create Filter Set dialog box appears.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-FB63C2CE-0C0D-43A0-B315-0F89279FF0D8&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Using%20Filters
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Figure 6-9. Create Filter Set Dialog Box

4. Enter a name for the filter, such as myfilter01, and click OK.
Your new filter name appears below the set under which it was created.

Figure 6-10. Specifying the Filter my_filter01

5. Repeat this procedure to cascade as many sets as you need using the filtering mechanism.
6. To edit a filter in the set:

a) Select the filter you want to edit.
b) Right-click the filter and choose Edit Set from the shortcut menu.

7. To rename a set created with filters:
a) Select the set that uses filters.
b) Right-click the set, and choose Rename Set from the shortcut menu.
c) Edit the name directly in the Domain Browser.
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7. Advanced Timing Analysis  (Ask a Question)

The following sections describe advanced timing analysis.

7.1. Understanding Inter-Clock Domain Analysis  (Ask a Question)

When functional paths exist across two clock domains (the register launching the data and the one
capturing it are clocked by two different clock sources), you must provide accurate specification of
both clocks to allow a valid inter-clock domain timing check. This is important especially when the
clocks are specified with different waveforms and frequencies.

When inter-clock domain paths exist in your design, consider whether setup and hold analysis needs
to be performed. Inter-clock domain analysis is controlled from the SmartTime options, as shown in
Activating Inter-Clock Domain Analysis section, and is enabled by default. When enabled, SmartTime
performs setup and hold checks between the clock domains unless a false path or asynchronous
clock group constraint has been applied. When disabled, the tool does not perform the setup and
hold checks.

If you have several clock domains that are subset of a single clock (for example, if you want to
measure clock tree delay from an input clock to a generated clock), you must configure Generated
Clock Constraints for each of the clock domains in order for SmartTime to execute the calculation,
and show timing for each of the inter-clock domain paths.

Once you include the inter-clock domains for timing analysis, SmartTime analyzes, for each inter-
clock domain, the relationship between all the active clock edges over a common period equal to
the least common multiple of the two clock periods. The new common period represents a full
repeating cycle (or pattern) of the two clock waveforms, as shown in the following figure.

Figure 7-1. New Common Period

For setup check, SmartTime considers the tightest relation launch-capture to ensure that the data
arrives before the capture edge. The hold check verifies that a setup relationship is not overwritten
by a following data launch.

7.2. Activating Inter-Clock Domain Analysis  (Ask a Question)

To activate the inter-clock domain checking:

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-6CBA2A60-1CCC-452E-94B5-1BEC4DB0B723&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Advanced%20Timing%20Analysis
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-808B42BC-FA1C-4025-A7FC-AA189F9CF512&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Inter-Clock%20Domain%20Analysis
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-AAEA04CD-04D9-407F-81FF-2D00B440A612&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Activating%20Inter-Clock%20Domain%20Analysis
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1. From the SmartTime Tools menu, choose Options.
The SmartTime Options dialog box appears, as shown in the following figure.

2. In the General category, check Include inter-clock domains in calculations for timing
analysis.

Figure 7-2. SmartTime Options Dialog Box for SmartFusion®  2, RTG4™, and IGLOO®  2

Figure 7-3. SmartTime Options Dialog Box for PolarFire®

3. Click OK to save the dialog box settings.
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7.3. Displaying Inter-Clock Domain Paths  (Ask a Question)

After you activate the inter-clock domain checking for a given clock domain CK1, SmartTime detects
automatically all other domains CKn with paths ending at CK1.

SmartTime creates inter-clock domain sets CKn to CK1 under the domain CK1. Each set allows you to
display the inter-clock domain paths between a given clock domain and CK1.
To display an inter-clock domain set:

1. Expand the receiving clock domain of the inter-clock domain in the Domain Browser to display
its related sets. For the inter-clock domain CK1 to CK2, expand clock domain CK2.

Figure 7-4. Expanding the Inter-Clock Domain

2. Select the inter-clock domain you want to expand from these sets.
All paths between the related two domains are displayed in Paths List in the same way as any
register to register set.

7.4. Deactivating a Specific Inter-Clock Domain  (Ask a Question)

To deactivate the inter-clock domain checking for the specific clock domains clk2->clk1, without
disabling this option for the other clock domains:

1. From the Tools menu, choose Constraints Editor > Primary Scenario to open the Constraints
Editor View.

2. In the Constraints Browser, double-click False Path under Exceptions.
The Set False Path Constraint dialog box appears.

3. Click the Browse button to the right of the From text box.
The Select Source Pins for False Path Constraint dialog box appears.

4. For Specify pins, select by keyword and wildcard.
5. For Pin Type, select Registers by clock names from the Pin Type drop-down list.
6. In the filter box, type the inter-clock domain name (for example, Clk2), and then click Filter.
7. Click OK to begin filtering the pins by your criteria.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-2765FF30-6EA2-4C9F-9C37-D50666D8D960&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Displaying%20Inter-Clock%20Domain%20Paths
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-782D82BA-AF00-4E22-88F1-8E26C1E34117&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Deactivating%20a%20Specific%20Inter-Clock%20Domain


 Libero SoC v2025.2
Advanced Timing Analysis

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 25

In this example, [get_clocks {Clk2}] appears in the From text box in the Set False Path Constraint
dialog box.

8. Repeat steps 3 to 7 for the TO option in the Set False Path Constraint dialog box and type Clk1
in the filter box.

9. Click OK to validate the new false path and display it in the Paths List of the Constraints Editor.

10. Click the Recalculate All icon  in the toolbar.
11. Select the inter-clock domain set clk2 -> clk1 in the Domain Browser.
12. Verify that the set does not contain any paths.

7.5. Changing Output Port Capacitance  (Ask a Question)

Output propagation delay is affected by both the capacitive loading on the board and the I/O
standard.

The I/O Attribute Editor in Chip Planner provides a way to set the expected capacitance to improve
the propagation delay model. SmartTime uses the modified delay model automatically for delay
calculations.
To change the output port capacitance and view the effect of this change in SmartTime Timing
Analyzer, see the following example. The following figure shows a delay of 6.603 ns from DFN1 to
output port Q based on the default loading of 5 pF.

Figure 7-5. Maximum Delay Analysis View

If your board has an output capacitance of 15 pf on Q, perform the following steps to update the
timing number.

1. Open the I/O Attribute Editor and change the output load to 15 pf.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-AEEF948D-E336-41B6-A810-0E5E94A30E4D&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Changing%20Output%20Port%20Capacitance
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Figure 7-6. I/O Attribute Editor

2. Select File > Save.
3. Select File > Close.
4. Open the SmartTime Timing Analyzer and confirm that the Clock to Output delay changed to

5.952 ns.
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8. Generating Timing Reports  (Ask a Question)

The following sections describe how to generate timing reports.

8.1. Types of Reports  (Ask a Question)

The following table lists the types of timing reports you can generate using SmartTime.

Table 8-1. Types of Timing Reports
Report Description

Timer Report Displays the timing information organized by clock domain.

Timing Violations Report Provides information about constraint violations.

Bottleneck Report Displays points in the design that contribute to the most
timing violations.

Datasheet Report Describes the characteristics of the pins, I/O technologies,
and timing properties in the design.

Constraints Coverage Report Displays the overall coverage of the timing constraints set on
the current design.

Combinational Loop Report Displays loops found during initialization.

Clock Domain Crossing Report Analyzes timing paths that cross from one clock domain (the
source clock) to another clock domain (the destination clock).

8.2. Generating a Timing Report  (Ask a Question)

The Timing Report allows you to determine whether timing problems exist in your design.

The Maximum Delay Analysis Timing Report lists the following information about your design:
• Maximum delay from input I/O to output I/O
• Maximum delay from input I/O to internal registers
• Maximum delay from internal registers to output I/O
• Maximum delays for each clock network
• Maximum delays for interactions between clock networks

To generate a Timing Report:

1. From the SmartTime Max/Min Delay Analysis View, choose Tools > Reports > Timer.
The Timing Report Options dialog box appears.

2. Select the options you want to include in the report, and then click OK.
The Timing Report appears in a separate window.

8.3. Understanding Timing Reports  (Ask a Question)

The following table lists the sections in the Timing Report.

Table 8-2. Timing Report Sections
Section Description

Header Lists the:
• Report type

• Version of Designer used to generate the report

• Date and time the report was generated

• General design information (name, family, and so on)

Summary Reports the timing information for each clock domain. By default, the clock domains
reported are the explicit clock domains that are shown in SmartTime. To filter the domains
and show only specific sections in the report, use the Timing Report Options dialog box.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-194FFBC5-DFC3-4718-9972-687F3B8B5982&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20Timing%20Reports
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-7581283E-0809-492C-90BF-2DC1E1892D42&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Types%20of%20Reports
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-459D78A4-CC32-48F1-887F-B66B3D931303&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Timing%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-DD3BBABA-2FC5-4931-9528-C82EA9BA1C13&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Timing%20Reports
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Table 8-2. Timing Report Sections (continued)
Section Description

Path Lists the timing information for different types of paths in the design. This section is
reported by default. You can deselect this option in the Timing Report Options dialog box.
By default, the number of paths displayed per set is 5. You can filter the domains using
the Timing Report Options dialog box. You can also view the stored filter sets in the
generated report using the Timing Report options. The filter sets are listed by name in
their appropriate section. The number of paths reported for the filter set is the same as for
the main sets. By default, the filter sets are not reported.

8.3.1. Clock Domains  (Ask a Question)

Paths are organized by clock domain.

8.3.2. Register to Register Set  (Ask a Question)

This set reports the paths from the registers clock pins to the registers data pins in the current clock
domain.

8.3.3. External Setup Set  (Ask a Question)

This set reports the paths from the top-level design input ports to the registers in the current clock
domain.

8.3.4. Clock to Output Set  (Ask a Question)

This set reports the paths from the registers clock pins to the top-level design output ports in the
current clock domain.

8.3.5. Register to Asynchronous Set  (Ask a Question)

This set reports the paths from registers to asynchronous control signals, such as asynchronous
set/reset.

8.3.6. External Recovery Set  (Ask a Question)

This set reports the external recovery check timing for asynchronous control signals, such as
asynchronous set/reset.

8.3.7. Asynchronous to Register Set  (Ask a Question)

This set reports the paths from asynchronous control signals, such as asynchronous set/reset, to
registers.

8.3.8. Inter-clock Domain  (Ask a Question)

This set reports the paths from the registers clock pins of the specified clock domain to the registers
data pins in the current clock domain. Inter-domain paths are reported by default.

8.3.9. Pin to Pin  (Ask a Question)

This set lists input to output paths and user sets. Input-to-output paths are reported by default. To
see the user- defined sets, use the Timing Report Options dialog box.

8.3.10. Input to Output Set  (Ask a Question)

This set reports the paths from the top-level design input ports to the top-level design output ports.

8.3.11. Expanded Paths  (Ask a Question)

Expanded paths can be reported for each set. By default, the number of expanded paths to report is
set to 1. You can select and change the number when you specify Timing Report options.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-77BF64C1-1EE8-4EBE-9225-17BD94839517&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Clock%20Domains
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-7A218215-8E51-47E8-8F48-5046B07C81BB&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Register%20to%20Register%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-AADF6163-2DA7-419E-BBD3-3A82ED92AE8E&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=External%20Setup%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-0FE449BD-C045-46E3-AA8A-3A2816053785&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Clock%20to%20Output%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-133ACDA0-9403-4822-B5A4-8AED34BF8E9F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Register%20to%20Asynchronous%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-421CABE4-5691-4F37-B4E8-0989CDB1F906&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=External%20Recovery%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-883F3A55-B141-43D9-A4B5-7EC9C10713AD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Asynchronous%20to%20Register%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-8493CA03-E755-48FB-998B-C96B08364933&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Inter-clock%20Domain
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-8C85406E-1C04-424A-8204-2573D0CCADA7&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Pin%20to%20Pin
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-7D5BAFCF-5942-4B6D-B2C8-991A094CA991&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Input%20to%20Output%20Set
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-7F97B788-7F3F-488F-AD97-91BC7E7F6683&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Expanded%20Paths
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Figure 8-1. Timing Report

8.4. Generating a Timing Violation Report  (Ask a Question)

The Timing Violations Report provides a Flat Slack Report centered around constraint violations.

To generate Timing Violations Report:

1. From the SmartTime Max/Min Delay Analysis View window, choose Tools > Reports > Timing
Violations.
The Timing Violations Report Options dialog box appears.

2. Select the options you want to include in the report, and then click OK.
The Timing Violations Report appears in a separate window.

8.5. Understanding Timing Violation Reports  (Ask a Question)

The following figure shows an example of a Timing Violations Report.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-C07DA75F-6344-4169-8665-63DC564E7574&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Timing%20Violation%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-A4CD44A0-6215-45DC-AEBF-B996FB48E37D&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Timing%20Violation%20Reports
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Figure 8-2. Sample Timing Violation Report

The following table lists the sections in the Timing Violation Report.

Table 8-3. Timing Violation Report Sections
Section Description

Header This section lists the:
• Report type

• Version of Designer used to generate the report

• Date and time the report was generated

• General design information (name, family, and so on)
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Table 8-3. Timing Violation Report Sections (continued)
Section Description

Paths This section lists the timing information for different types of paths in the design.
The number of paths displayed is controlled by the following parameters:
• A maximum slack threshold to report

• A maximum number or path to report

By default, the slack threshold is 0 and the number of paths is limited. The
default maximum number of paths reported is 100. All clocks domains are mixed
in this report. The paths are listed by decreasing slack.
You can also choose to expand one or more paths. By default, no paths are
expanded. For details, see the Timing Violation Report options.

8.6. Generating a Constraints Coverage Report  (Ask a Question)

The Constraints Coverage Report contains information about the constraints in the design.

To generate a Constraints Coverage Report:

1. From the SmartTime Max/Min Delay Analysis View, choose Tools > Reports > Constraints
Coverage.

2. Select the text format and number of unconstrained instances and click OK.
The report appears in a separate window.

8.7. Understanding Constraints Coverage Reports  (Ask a Question)

The Constraints Coverage Report shows the overall coverage of the timing constraints set on the
current design. You can generate this report either from within Designer or within SmartTime
Analyzer.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-C07D5AB2-52F3-48A8-BDBA-00217016E7F9&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Constraints%20Coverage%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-0C495E8A-9BB1-4A8A-AE95-F54EC516A62F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Constraints%20Coverage%20Reports
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Figure 8-3. Sample Constraints Coverage Report

The following table lists the sections in the Constraints Coverage Report.

Table 8-4. Constraints Coverage Report Sections
Section Description

Coverage Summary Shows statistical information about the timing constraint in the
design. For each type of timing checks (Setup, Recovery, Output, Hold,
and Removal), it specifies how many are Met (there is a constraint
and it is satisfied), Violated (there is a constraint and it is not
satisfied), or Untested (no constraint was found).

Results by Clock Domain This section provides a coverage summary for each clock domain.

Enhancement Suggestions Reports, per clock domain, a list of constraints that can be added to
the design to improve the coverage. It also reports if some options
impacting the coverage can be changed.
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Table 8-4. Constraints Coverage Report Sections (continued)
Section Description

Detailed Stats Provides detailed suggestions about specific clocks or I/O ports
that may require to be constrained for every pin/port that requires
checks.

8.8. Generating a Bottleneck Report  (Ask a Question)

To generate a Bottleneck Report:

From the SmartTime Max/Min Delay Analysis View, choose Tools > Reports > Bottleneck. The
report appears in a separate window.

8.9. Understanding Bottleneck Reports—SmartFusion 2, IGLOO 2, RTG4, and
PolarFire  (Ask a Question)

A bottleneck is a point in the design that contributes to multiple timing violations. The Bottleneck
Report lists the bottlenecks in the design. You can generate this report from SmartTime Analyzer.
Notes: The bottleneck can be computed only when a cost type is defined. There are two cost type
options available:
• Path count: Associates the severity of the bottleneck to the count of violating/critical paths that

traverse the instance.
• Path cost: Associates the severity of the bottleneck to the sum of the timing violations for the

violating/critical paths that traverse the instance.

Figure 8-4. Sample Bottleneck Report

The following table lists the sections in the Bottleneck Report.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-AE5DFB04-E75B-4274-9525-C07A97EAE8C7&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Bottleneck%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-3128A520-78FD-4FB5-A3BB-4EB43F4D825E&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Bottleneck%20Reports%E2%80%94SmartFusion%202%2C%20IGLOO%202%2C%20RTG4%2C%20and%20PolarFire
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Table 8-5. Bottleneck Report Sections
Part Description

Device Description Contains general information about the design, including:
• Design name

• Family

• Die

• Package

• Software version

Bottleneck Analysis Lists the core of the bottleneck information. It is organized into two
columns:
• Instance Name: Refers to the output pin name of the instance.

• Path Count: Shows the number of violating paths that include the
instance pin.

8.10. Generating a Datasheet Report  (Ask a Question)

The Datasheet Report shows information about a design’s external characteristics.

To generate a Datasheet Report:

1. From the SmartTime Max/Min Delay Analysis View, choose Tools > Reports > Datasheet.
The report appears in a separate window.

8.11. Understanding Datasheet Reports  (Ask a Question)

The Datasheet Report displays the external characteristics of the design. You can generate this
report from SmartTime Max/Min Delay Analysis View.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-34A4889B-DB12-4DE4-89FE-F2EEE1A54B2A&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Datasheet%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-06FBED96-3725-431D-8533-D1306FE0EB86&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Datasheet%20Reports


 Libero SoC v2025.2
Generating Timing Reports

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 35

Figure 8-5. Sample Datasheet Report

The following table lists the tables in the Datasheet Report.

Table 8-6. Datasheet Report Tables
Table Description

Pin Description Provides the port name in the netlist, location on the
package, type of port, and I/O technology assigned to it.
Types can be input, output, or clock. Clock ports are ports
shown as "clock" in the Clock domain browser.

DC Electrical Characteristics Provides the parameters of the different I/O technologies
used in the design. The number of parameters displayed
depends on the family for which you have created the
design.

AC Electrical Characteristics Provides the timing properties of the design ports
For each clock, this section includes the maximum frequency.
For each input, it includes the external setup, external hold,
external recovery, and external removal for every clock
where it applies. For each output, it includes the clock-to-
out propagation time. This section also displays the input-to-
output propagation time for combinational paths.



 Libero SoC v2025.2
Generating Timing Reports

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 36

8.12. Generating a Combinational Loop Report  (Ask a Question)

The Combinational Loop Report shows all loops found during initialization and reports pins
associated with the loop(s) and the location where a loop is broken.

To generate a Combinational Loop Report:

1. From the Tools menu, choose Reports > Combinational Loops.
The Combinational_Loops Report Options dialog box appears.

2. Select either Plain Text or Comma Separated Values.
3. Click OK.

8.13. Understanding Combinational Loop Reports  (Ask a Question)

The Combinational Loop Report shows all loops found during initialization, reports the pins
associated with the loops, and identifies the locations where loops are broken.

Figure 8-6. Sample Combinational Loop Report

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-21977408-F775-41F5-A28B-48B2B47D28F6&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Combinational%20Loop%20Report
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-254DAF46-A0DA-445F-87DA-F56105B9F679&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Understanding%20Combinational%20Loop%20Reports
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8.14. Generating a Clock Domain Crossing (CDC) Report  (Ask a Question)

The Clock Domain Crossing (CDC) Report analyzes timing paths that cross from one clock domain
(the source clock) to another clock domain (the destination clock). The CDC Report helps identify
instances where there may be data loss or metastability issues.

To generate the CDC Report:

1. From the Tools menu, choose Reports > Clock Domain Crossing (CDC)..
The Clock Domain Crossing Report Options dialog box appears.

2. Select either CDC Table or Comma Separated Values.
3. Click OK.

Selecting CDC Table displays a graphical table with color-coded cells. Each cell represents a CDC
type between the source clock and the destination clock domains that have constraints. Clocks
without constraints do not appear in the CDC table.

Figure 8-7. Graphical Table of CDC Types

The attributes present in the path table are as follows:
• Source Clock: Source of the clock
• Destination Clock: Destination of the clock
• Worst Slack (ns): Worst slack of the CDC path in nanoseconds
• Worst Slack Edge: Source/sink edge for the worst path of CDC
• Max Delay Cstr: See the following table.

Value Description

Yes All paths in CDC have set_max_delay applied

No No paths in CDC have the constraints applied

Partial Any path in CDC has the constraint applied

• Multicycle Path Cstr: see the following table.

Value Description

Yes All paths in CDC have set_multicycle_path applied

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-389F6D5F-520E-4A29-B203-1B27AAFAA436&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Generating%20a%20Clock%20Domain%20Crossing%20%28CDC%29%20Report
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Value Description

No No paths in CDC have the constraints applied

Partial Any path in CDC has the constraint applied

• Clock Group Cstr: See the following table.

Value Description

Yes CDC has set_clock_group applied

No CDC does not have set_clock_group applied

• Clock Uncertainty Cstr: Uncertainty value for the worst path in CDC; otherwise, the clock
uncertainty field is left empty.

• Num of Paths: Number of paths in CDC. For User Ignored paths, the value is 0.
• Clock Pair Status: Status can be Timed Safe, Timed Unsafe or User Ignored.

In the CDC Report dialog box, you can select the clocks to view or hide. Clicking the Clock
Selection button at the top left of the dialog box lists all clocks that can be viewed or hidden. By
default, all clocks are checked and visible. To hide a clock, clear its check box.

Figure 8-8. Showing or Hiding Clocks

The following table describes the colors in the CDC Report shown in the preceding figure.

Table 8-7. Definition of Colors in the CDC Report
Pattern Status Color

Paths from the source clock domain to the destination clock domain have all
been disabled by false path or clock group constraints.

User-Ignored Paths Light blue

No Paths found from the source clock domain to the destination clock domain. No Paths Gray

The source and destination clocks are synchronous: Both the clocks have a
common primary clock and paths are found from the source clock domain to
the destination clock domain.

Timed Dark Blue

Synchronizers have been identified on all paths between source and
destination clocks.

Synchronized Orange

There are certain scenarios related to the path table as explained in the following:
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1. When CDC Report is generated, path table is shown by default for all CDC having paths. Each
row shows the worst slack for a clock crossing. Similarly, when clicking on a particular CDC
crossing in CDC Report, you can have a single row showing the worst slack for CDC crossing.
Example: The path table shown in the following figure, the worst path for
reg_com_clk_10mhz to reg_com_clk_5mhz has the worst slack of 93.541. The same path is
displayed by default, when the CDC crossing is selected.

Figure 8-9. Worst Path with Slack 93.541 ns

Figure 8-10. Smarttime Showing the Worst Path with Slack 93.541 ns

2. Clicking on the CDC box shows the worst slack for a clock crossing as in path table in the
following figure.

Figure 8-11. Highlighted CDC Box Showing the Worst Slack in Path Table

Clicking on the same CDC box again shows details for all the clocks selected in the CDC
Report.
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Figure 8-12. CDC Path Table Showing All Clocks on Deselecting the Selected CDC Box

For all clocks having large names, tool-tips for columns have been added.

Figure 8-13. CDC Path Table Showing Tool-Tip for a Source Clock Name

3. Selecting/deselecting clocks in clock selection dynamically changes the path table along with
the CDC table. Both the tables are in sync. Example: Here, clk_input_100mhz is selected,
therefore, the clock is displayed in CDC table and path table.

Figure 8-14. CDC Table in Sync with Clock Selection Section

When the clock clk_input_100mhz is unselected, then the same clock is removed from the
CDC table. The crossings related to the clock are also removed from the path table as shown
in the following figure.
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Figure 8-15. Deselecting a Clock in Clock Selection Section Syncs the Path Table Accordingly

After clicking any one of the four options in the CDC category, the clock table is filtered according
to the CDC category selected.
In the following scenario, the Timed button has been selected and Timed safe CDC is displayed
only in the clock table.

Figure 8-16. CDC Report When Timed Button is Selected in CDC Category

Clicking on the same CDC category shows the details for all the clocks selected in CDC Report.
Selecting/unselecting clocks in clock selection does dynamically change the clock table along with
the CDC table.
In the following figure, the User Ignored CDC category button is chosen and clk_input_100mhz is
selected. Therefore, the clock is displayed in CDC table and clock table.
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Now, when clock clk_input_100mhz is unselected, the same clock is moved from CDC table and
the crossings related to that clock are also removed from clock table. Therefore, when the User
Ignored CDC category is selected, entries related to clk_input_100mhz are not visible.

After right-clicking a CDC box, you can choose to Copy, Add a Clock Group Constraint or Go to
Timing Explorer.
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Figure 8-17. CDC Report with Go to Timing Explorer Option

Selecting the Go to Timing Explorer option opens the Timing Explorer dialog box.

Figure 8-18. Timing Report Explorer

There are corner scenarios when cross probing between CDC and Timing Explorer:
Scenario 1:
This is a scenario where difference is seen between SmartTime and Verify timing, when two
clocks are defined on same port and when cross probing for CDC reg_com_clk_10mhz and
reg_com_clk_5mhz is unable to find the same in Timing Report Explorer.
The constraints are as follows:

 create_clock -name {reg_com_clk_10mhz} -period 100 -waveform {0 50 } [ get_ports 
{ reg_com_clk_10mhz } ]
create_clock -name {reg_com_clk_5mhz} -period 200 -waveform {0 100 } -add [ get_ports 
{ reg_com_clk_10mhz } ]

The Timing Report Explorer does not pick reg_com_clk_5mhz as destination clock, and Smart
time does pick the reg_com_clk_10mhz and reg_com_clk_5mhz pair as CDC, as shown in the
following figure.
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Figure 8-19. Timing Report Explorer Snapshot - 1

Figure 8-20. Timing Report Explorer Snapshot - 2

Figure 8-21. SmartTime Snapshot

Timing Explorer is picking the worst slack path for a pair of start and end point. Therefore, you
can miss CDC and other reg to reg paths with lower slack values.
Scenario 2:
This is a scenario where due to different operating conditions set in Smart Time, you can have
different results, when cross probing between CDC and Timing Report Explorer. SmartTime and
CDC are in sync.

Figure 8-22. Worst Slack of 97.958 ns in Timing Report Explorer

Figure 8-23. Worst Slack of 98.154 ns in SmartTime
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Figure 8-24. Operating Conditions

The Timing Report Explorer reports the path from slow_lv_lt, and SmartTime reports using
the operating condition fast_hv_lt. When the operating condition in SmartTime is changed to
slow_lv_lt, the worst slack becomes the same as in the Timing Report Explorer.

Figure 8-25. Slack After Changing the Operating Condition to slow_lv_lt

CDC Reports worst path for a particular corner selected in SmartTime, and Timing Report
Explorer reports the worst path across all the corners.
In such cases, you can see changes in values when navigating from CDC to Timing Report
Explorer. To make you aware of such situations, Corner Info column is added to display the
operating conditions.
Note: 
• The path details for the same clock crossing (C1 to C1) are not shown in the path tale as they

are not valid clock crossings and are currently shown as timed safe by default in CDC Report.
• The clock table has CDC details only related to clocks checked in clock selection from CDC

Report.
• Path table will not show any CDC having no paths.
• For User Ignored CDC columns, “Worst Slack (ns)”, “Worst Slack Edge”, “Max Delay Cstr”,

“Multicycle Path Cstr”, and “Clock Uncertainty Cstr” are empty.
• Cross probing is allowed to Timing Report Explorer for the same clock crossing (C1 to C1).
• For User Ignored CDC category, Corner Info column is empty.

Selecting Comma Separated Value exports the CDC Report to a CSV file. If you select this
option, a window appears in which you assign a name to the CSV file and specify the location
where it will be exported. The CSV file shows details about the CDC between each clock domain
in numeric format. Each CDC type is represented as a number similar to colors in the table. The
CSV file includes an explanation of each number type and CDC type.
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Figure 8-26. Sample CSV Report



 Libero SoC v2025.2
Timing Concepts

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 47

9. Timing Concepts  (Ask a Question)

The following sections describe timing concepts associated with the RTG4 FPGA Clock Conditioning
Circuit with PLL configuration.

9.1. Static Timing Analysis Versus Dynamic Simulation  (Ask a Question)

Static Timing Analysis (STA) offers an efficient technique for identifying timing violations in your
design and ensuring that it meets all your timing requirements. You can communicate timing
requirements and timing exceptions to the system by setting timing constraints. Then a static
timing analysis tool checks and reports setup, and holds violations and violations on specific path
requirements.

STA is well suited for traditional synchronous designs. The main advantage of STA is that, unlike
dynamic simulation, it does not require input vectors. It covers all possible paths in the design and
does all the above with relatively low run-time requirements. The major disadvantage of STA is that
the STA tools do not automatically detect false paths in their algorithms.

9.2. Delay Models  (Ask a Question)

The first step in timing analysis is the computation of single component delays. These components
can be either a combinational gate or block or a single interconnect connecting two components.

Gates that are part of the library are pre-characterized with delays under different parameters, such
as input-slew rates or capacitive loads. Traditional models provide delays between each pair of I/Os
of the gate and between rising and falling edges.

The accuracy with which interconnect delays are computed depends on the design phase. These can
be estimated using a simple Wire Load Model (WLM) at the pre-layout phase or a more complex
Resistor and Capacitor (RC) tree solver at the post-layout phase.

9.3. Timing Path Types  (Ask a Question)

Path delays are computed by adding delay values across a chain of gates and interconnects.
SmartTime uses this information to check for timing violations. Traditionally, timing paths are
presented by static timing analysis tools in four categories or "sets."

• Paths between sequential components internal to the design: SmartTime displays this
category under the Register to Register set of each displayed clock domain.

• Paths that start at input ports and end at sequential components internal to the design:
SmartTime displays this category under the External Setup and External Hold sets of each
displayed clock domain.

• Paths that start at sequential components internal to the design and end at output ports:
SmartTime displays this category under the Clock to Out set of each displayed clock domain.

• Paths that start at input ports and end at output ports: SmartTime displays this category
under the Input to Output set.

9.4. Maximum Clock Frequency  (Ask a Question)

Generally, you set clock constraints on clocks for which you have a specified requirement. The
absence of violations indicates that this clock can run at least at the specified frequency. However,
in the absence of such requirements, you may still be interested in computing the maximum
frequency of a specific clock domain.

To obtain the maximum clock frequency, a static timing analysis tool computes the minimum
period for each path between two sequential elements. To compute the maximum period, the tool
evaluates the maximum data path delay and the minimum skew between the two elements and the
setup on the receiving sequential element. It also considers the polarity of each sequential element.
The maximum frequency is the inverse of the largest value among the maximum period of all the

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1E628CEB-C29F-4E76-B2D3-29E1CC3B4795&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Concepts
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F0F0CA00-B979-45B9-9C03-B91F0802457C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Static%20Timing%20Analysis%20Versus%20Dynamic%20Simulation
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-9D4DF93F-B3AD-430A-B0AD-783D70DCCD12&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Delay%20Models
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D68FCDB0-7C07-4637-9A4E-47DD2B06FAF7&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Path%20Types
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-8B6FC063-E2FC-452F-B0F0-F0C12071D52D&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Maximum%20Clock%20Frequency
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paths in the clock domain. The path responsible for limiting the frequency of a given clock is called
the “critical path.”

9.5. Setup Check  (Ask a Question)

The setup and hold check ensures that the design works as specified at the required clock
frequency.

Setup check specifies when data is required to be present at the input of a sequential component
so that the clock can capture the data effectively into the component. Timing analyzers evaluate the
setup check as a maximum timing budget allowed between adjacent sequential elements.

For more information about how setup check is processed, see section Arrival Time, Required Time,
and Slack.

9.6. Arrival Time, Required Time, and Slack  (Ask a Question)

You can use arrival time and required time to verify timing requirements in the presence of
constraints. The following simple example is applied to verify the clock requirement for setup
between sequential elements in the design.

The arrival time represents the time at which the data arrives at the input of the receiving sequential
element. In this example, the arrival time is considered from the setup launch edge at CK, taken as
a time reference (instant zero). It follows the clock network along the blue line until the clock pin on
FF1 (delay d1). Then it continues along the data path always following the blue line until the data pin
D on FF2. Therefore:

Arrival_TimeFF2:D = d1 + d2

The required time represents when the data is required to be present at the same pin FF2:D.
Consider in this example, in the presence of an FF with the same polarity, the capturing edge is
simply one cycle following the launch edge. Using the period T provided to the tool through the
clock constraint, the event gets propagated through the clock network along the red line until the
clock pin of FF2 (delay d3), taking FF2 setup (delay d4) into account. This means the clock constraint
requires the data to be present d4 time before the capturing clock edge on FF2. Therefore, the
required time is:

Required_TimeFF2:D = T + d3 - d4

If the slack is negative, the path is violating the setup relationship between the two sequential
elements.

The slack is simply the difference between the required time and arrival time: SlackFF2:D =
Required_TimeFF2:D - Arrival_TimeFF2:D

Figure 9-1. Arrival Time and Required Time for Setup Check

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-5F397272-04CE-488D-81F5-046B2DB6733C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Setup%20Check
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D8B64789-BB83-444B-A1F5-4D3BB1240157&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Arrival%20Time%2C%20Required%20Time%2C%20and%20Slack
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9.7. Timing Exceptions Overview  (Ask a Question)

Use timing exceptions to overwrite the default behavior of the design path.

Timing exceptions include:

• Setting multicycle constraint to specify paths that (by design) will take more than one cycle.
• Setting a false path constraint to identify paths that must not be included in the timing analysis or

the optimization flow.
• Setting a maximum/minimum delay constraint on specific paths to relax or to tighten the original

clock constraint requirement.

9.8. Clock Skew  (Ask a Question)

The clock skew between two sequential components is the difference between the insertion delays
from the clock source to the clock pins of these components. SmartTime calculates the arrival time
at the clock pin of each sequential component. Then it subtracts the arrival time at the receiving
component from the arrival time at the launching component to obtain an accurate clock skew.

Both setup and hold checks must account for clock skew. However, for setup check, SmartTime
looks for the smallest skew. This skew is computed by using the maximum insertion delay to the
launching sequential component and the shortest insertion delay to the receiving component.

For hold check, SmartTime looks for the largest skew. This skew is computed by using the shortest
insertion delay to the launching sequential component and the largest insertion delay to the
receiving component.

SmartTime makes the distinction between setup and hold checks and hold checks automatically.

9.9. Cross Probing  (Ask a Question)

Design objects displayed in SmartTime can be cross-probed into other Libero SoC tools. Libero
SoC allows cross-probing from SmartTime to the Constraints Editor (but not vice versa) and from
SmartTime to Chip Planner (but not vice versa). When cross-probing from SmartTime to one of the
other tools, both SmartTime and the other tool must first be opened.

9.9.1. Cross-Probing from SmartTime into the Constraints Editor  (Ask a Question)

To add a timing exception constraint from SmartTime and have the Constraints Editor display the
constraint:

1. From the SmartTime Maximum or Minimum Delay Analysis view, click a timing path to add a
timing exception constraint.

2. When the Constraints Editor’s Add Constraint dialog box appears, the fields for source (from) pin
and destination (to) pin are populated with the correct names from the timing path you selected.

9.9.2. Adding a Timing Exception Constraint from a Timing Path  (Ask a Question)

To add a timing exception constraint from a timing path in SmartTime Max/Min Delay Analysis View:

1. Open SmartTime (Design Flow Window > Verify Timing > Open interactively).
2. Open the Constraints Editor (Constraint Manager > Timing Tab > Edit with Constraints

Editor).
3. Select Max/Min Delay Analysis View, and then right-click a timing path in the table.
4. Select a timing exception constraint to add:

• False Path Constraint
• Maximum Delay Constraint
• Minimum Delay Constraint
• Multicycle Path Constraint

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-3A4A4556-9627-4BB8-BD99-0F2C180049A3&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Exceptions%20Overview
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-2F86AFA9-3D50-4DCC-88BD-8F90D34A4BA6&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Clock%20Skew
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E77B5846-01E9-4600-9E93-7B82CA335689&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Cross%20Probing
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-7244BA72-3DDA-4F99-8898-EF2E677E1021&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Cross-Probing%20from%20SmartTime%20into%20the%20Constraints%20Editor
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-37E9EAFD-6B04-417D-AD65-E8A4CEC3ABB0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Adding%20a%20Timing%20Exception%20Constraint%20from%20a%20Timing%20Path
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Figure 9-2. Add Timing Constraint from SmartTime’s Reported Timing Path

Note:  If the Constraint Editor is not open, the Add Max/Min Delay, False Path, and Multicycle
Path Constraint menu items are grayed out.

5. Add the Constraint in the Add Constraint dialog box. The source/from pin and destination/to
pin fields are populated with the appropriate pin names captured from the SmartTime reported
path (Source Pin and Sink Pin) you clicked.
a) Click OK to exit the Add Constraint dialog box.
b) Click Save in the Constraints Editor.
c) Exit the Constraints Editor.
d) Exit SmartTime.
e) If the newly added constraint that is added to a file (the Target file) is used for Place and

Route and Verify Timing, rerun Place and Route.
f) Open SmartTime Maximum/Minimum Delay Analysis View.
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Figure 9-3. Add Maximum Delay Constraint

9.9.3. Cross-Probing from SmartTime to Chip Planner  (Ask a Question)

Cross-probing of design objects is available from SmartTime to Chip Planner, but not vice versa.
Cross-probing allows you to select a design object in one application and display the selected object
in another application.

Complete the Place and Route step on the design, and then open both SmartTime and Chip Planner.

Because Libero SoC allows you to cross-probe design objects from SmartTime to Chip Planner,
you can better understand how the two applications interact with each other. With cross-probing,
a timing path not meeting timing requirements can be fixed with relative ease when you see the
less-than-optimal placement of the design object (in terms of timing requirements) in Chip Planner.
Cross-probing from SmartTime to Chip Planner is available for the following design objects:
• Macros
• Ports
• Nets/Paths

To cross-probe from SmartTime to Chip Planner, use a design macro in SmartTime.

9.9.4. Design Macro Example  (Ask a Question)

1. Make sure the design completed the Place and Route step successfully.
2. Open SmartTime Maximum/Minimum Analysis View.
3. Open Chip Planner.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-2ECE2322-538A-455A-82D6-AD553591A7AD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Cross-Probing%20from%20SmartTime%20to%20Chip%20Planner
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-6A6B88F7-C435-4852-BC01-D165D92CEEB2&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Design%20Macro%20Example
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4. In the SmartTime Maximum Analysis View, right-click the instance Q[2] in the Timing Path Graph
and choose Show in Chip Planner.
The Properties window in Chip Planner displays the properties of Q[2]. With cross-probing, the
Q[2] macro is selected in Chip Planner’s Logical View and highlighted (white) in the Chip Canvas.
Note: If Chip Planner is not open, Show in Chip Planner is gray and unavailable.

Figure 9-4. Cross-Probing—Macro

5. If necessary, zoom in to view the highlighted Q2 Macro in the Chip Canvas.

9.9.5. Timing Path Example  (Ask a Question)

The following procedure provides an example of working with timing paths.

1. Make sure the design completed the Place and Route step successfully .
2. Open SmartTime Maximum/Minimum Analysis View.
3. Open Chip Planner.
4. In the SmartTime Maximum/Minimum Analysis View, right-click the net CLK_ibuf/U0/

U_IOPAD:PAD in the table and choose Show Path in Chip Planner.
The net is selected (highlighted in red) in the Chip Canvas view and the three macros connected
to the net are highlighted in white in the Chip Canvas view.
Note:  If Chip Planner is not open, Show Path in Chip Planner is gray and unavailable.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-03E576CE-435E-45C5-8307-01DC32E4695E&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Path%20Example
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Figure 9-5. Cross-Probing—Timing Path

Figure 9-6. Cross-Probing Path from Max/Min Delay Analysis View Table

Instead of performing step 4, you can right-click a path in the Max/Min Delay Analysis View and
choose Show Path in Chip Planner to cross-probe the path.

9.9.6. Port Example  (Ask a Question)

1. Make sure the design completed the Place and Route step successfully.
2. Open SmartTime Maximum/Minimum Analysis View.
3. Open Chip Planner.
4. In the SmartTime Maximum/Minimum Analysis View, right-click the Port “CLK” in the Path and

choose Show in Chip Planner.
The Port “CLK” is selected and highlighted in the Chip Planner Port View.
Note: If Chip Planner is not open, Show in Chip Planner is gray and unavailable.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-C68CF16C-F0D6-4934-A0A3-2CE814FB7A9A&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Port%20Example
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Figure 9-7. Cross-Probing—Port

From the Properties View inside Chip Planner, you will find useful information about the Port
“CLK” you are cross- probing:
• Port Type
• Port Placement Location (X-Y coordinates)
• I/O Bank Number
• I/O Standard
• Pin Assignment
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Figure 9-8. Properties View of Port “CLK”
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10. SmartTime Tutorials  (Ask a Question)

The following sections describe SmartTime tutorials.

10.1. Tutorial 1—32-Bit Shift Register with Clock Enable  (Ask a Question)

This tutorial describes how to enter a clock constraint for the 32-bit shift register on SmartFusion 2
device.

You use the SmartTime Constraints Editor and perform post-layout timing analysis using the
SmartTime Timing Analyzer.

Figure 10-1. 32-Bit Shift Register

To set up your project:

1. Invoke Libero SoC. From the Project menu, choose New Project.
2. Type sf2_shift32 for your new project name and browse to a folder for your project location.

3. Select Verilog as the Preferred HDL Type.
4. Leave all other settings at their default values.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-CCF26330-263C-4D48-8B48-D62A6DEA7116&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20Tutorials
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4658D101-06D8-4909-BD3C-E535FBC3DFA6&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Tutorial%201%E2%80%9432-Bit%20Shift%20Register%20with%20Clock%20Enable


 Libero SoC v2025.2
SmartTime Tutorials

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 57

Figure 10-2. New Project Creation—32-Bit Shift Register

5. Click Next to go to Device Selection page. Make the following selection from the pull-down
menus:
• Family: SmartFusion 2
• Die: M2S090TS
• Package: 484 FBGA
• Speed: STD
• Core Voltage: 1.2V
• Range: COM

Figure 10-3. Selections from Pull-down Menus

6. Click the M2S090TS-1FG484 part number and click .
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7. Accept the default settings in the Device Settings page and click Next.
8. Accept the default settings in the Design Template page and click Next.
9. Click Next to go to the Add Constraints page.
10. Because you are not adding any constraints, click Finish to exit the New Project Creation wizard.
11. To add a new HDL file, select File> New> HDL.

The Create a new HDL file dialog box appears.
12. Name the HDL file shift_reg32 as shown in the following figure, and click OK.

Figure 10-4. Create a New HDL File Dialog Box

13. Copy the following code and paste it into the Verilog file:
module shift32 ( Q,CLK,D,EN,RESET); input D,EN,CLK,RESET;
output[31:0] Q; reg [31:0] Q_int;
assign Q=Q_int;
always@ (posedge CLK) begin
if(RESET)
Q_int<=0; else begin if(EN)
Q_int<={Q_int[30:0],D}; end
end endmodule

14. Check the HDL file to confirm there are no syntax errors.
15. Confirm that the shift_reg32 design appears in the Design Hierarchy window, as shown in the

following figure.
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Figure 10-5. shift_reg32 in the Design Hierarchy Window

16. In the Design Flow window, double-click Synthesize to run Synplify Pro with default settings.
A green check mark appears next to Synthesize when Synthesis is successful, as shown in the
following figure.

Figure 10-6. Synthesis and Compile Complete—32-Bit Shift Register with Clock Enable

10.1.1. Add a Clock Constraint—32-Bit Shift Register  (Ask a Question)

To add a clock constraint to your design:

1. In the Design Flow window, double-click Manage Constraints.
The Constraint Manager appears.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-A92830BE-0D96-4F03-B396-593DF16AC74A&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Add%20a%20Clock%20Constraint%E2%80%9432-Bit%20Shift%20Register
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Figure 10-7. Constraint Manager

2. Click the Timing tab.
3. Click Edit with Constraints Editor > Edit Place and Route Constraints.

Figure 10-8. Constraints Editor—Add Clock Constraint

The Constraints Editor appears.
4. In the Constraints Editor, right-click Clock under Requirement and select Add Clock

Constraint.
The Create Clock Constraint dialog box appears.



 Libero SoC v2025.2
SmartTime Tutorials

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 61

Figure 10-9. Create Clock Constraint Dialog Box

5. From the Clock Source drop-down menu, choose the CLK pin.
6. In the Clock Name field, type my_clk.

7. Set the Frequency to 250 MHz (as shown in the following figure) and accept all other default
values.

Figure 10-10. Add a 250 MHz Clock Constraint

8. Click OK to continue.
The clock constraint appears in the SmartTime Constraints Editor.
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Figure 10-11. 250 MHz Clock Constraint in the Constraint Editor

9. From the File menu, choose Save to save the constraints.
10. From the SmartTime File menu, choose Exit to exit SmartTime.

Libero creates a constraint file to store the clock constraint. This file appears in the Constraint
Manager. It is named user.sdc and designated as Target.
Note: A target file is used to store newly added constraints from the Constraint Editor. If you
invoke the Constraint Editor with no SDC timing constraint file present, Libero SoC creates the
user.sdc file and marks it as Target to store the timing constraints you create in the Constraint
Editor.

11. In the Constraint Manager, check the check boxes under Place and Route and Timing
Verification to associate the constraint file to the tools. The constraint file is used for both
Place and Route and Timing verification.
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Figure 10-12. SDC Constraint File and Tool Association

10.1.2. Run Place and Route  (Ask a Question)

To run Place and Route:

1. Right-click Place and Route and choose Configure Options.
The Layout Options dialog box appears.

2. Click the check box to enable Timing-driven layout and accept the other default values shown in
the following figure.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-6FDEC6AA-6471-4671-BDC7-FFD8005DCE60&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Run%20Place%20and%20Route
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Figure 10-13. Layout Options Dialog Box

3. Click OK to continue.
4. In the Design Flow window, double-click Place and Route to start the Place and Route.

10.1.3. Maximum Delay Analysis with Timing Analyzer—32-Bit Shift Register Example  (Ask a Question)

The SmartTime Maximum Delay Analysis window shows the design maximum operating frequency
along with any setup violations.

To perform maximum delay analysis:

1. Right-click Open SmartTime in the Design Flow window and choose Open Interactively to
open SmartTime. The Maximum Delay analysis window appears. A green check next to the clock
name indicates there are no timing violations for that clock domain. The Summary page displays
a summary of the clock domain timing performance.
The Maximum Delay Analysis Summary appears with the following information shown:
• Maximum operating frequency for the design
• External setup and hold requirements
• Maximum and minimum clock-to-out times. In this example, the maximum clock frequency

for CLK is 609.75 MHz.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-A810F40E-C9E4-453F-A92E-1DBF36D6824C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Maximum%20Delay%20Analysis%20with%20Timing%20Analyzer%E2%80%9432-Bit%20Shift%20Register%20Example
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Figure 10-14. Maximum Delay Analysis—Summary

2. Expand my_clk to display the Register to Register, External Setup, and Clock to Output path sets.

Figure 10-15. SmartTime Register-to-Register Delay

3. Select Register to Register to display the register-to-register paths.
The window displays a list of register- to-register paths and detailed timing analysis for the
selected path. All the slack values are positive, indicating that there are no setup time violations

4. Double-click a path row to open the Expanded Path window.
The window shows a calculation of the data arrival and required times, along with a schematic of
the path.
Note: Timing numbers in the reports may vary slightly with different versions of the Libero
software, and may not be what you see when you run the tutorial.
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Figure 10-16. Register-to-Register Expanded Path View

5. Select External Setup to display the Input to Register timing.
6. Select Path 3.

The Input Arrival time from the EN pin to Q_int[27]:EN is 4.547 ns.

Figure 10-17. SmartTime—Input to Register Path Analysis

7. Select Clock to Output to display the register to output timing.
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8. Select Path 1.
The maximum clock to output time from Q_int[16]:CLK to Q[16 ] is 9.486 ns.

Figure 10-18. SmartTime Clock to Output Path Analysis

10.1.4. Minimum Delay Analysis with Timing Analyzer—32-Bit Shift Register Example  (Ask a Question)

The SmartTime Minimum Delay Analysis window identifies any hold violations that exist in the
design.

To perform minimum delay analysis:

1. From the SmartTime Analysis window, choose Tools > Minimum Delay Analysis.
The Minimum Delay Analysis View appears, as shown in the following figure.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4F1C339B-6A85-4099-A1F5-9B9FB04905CE&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Minimum%20Delay%20Analysis%20with%20Timing%20Analyzer%E2%80%9432-Bit%20Shift%20Register%20Example
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Figure 10-19. SmartTime Minimum Delay Analysis View—Summary

2. Expand my_clk to display Register to Register, External Hold, Clock to Output, Register to
Asynchronous, External Removal, and Asynchronous to Register path sets.

3. Click Register to Register to display the reg to reg paths.
The window displays a list of register to register paths and detailed timing analysis for the
selected path. All the slack value are positive, indicating that there are no hold time violations.

4. Click to select the first path and observe the hold analysis calculation details, as shown in the
following figure.
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Figure 10-20. SmartTime Minimum Delay Analysis

10.1.5. Changing Constraints and Observing Results—32-Bit Shift Register Example  (Ask a Question)

You can use the Constraints Editor to change your constraints and view the results in your design.
The following procedure describes how.

1. Open the Constraints Editor (Constraints Manager > Timing Tab > Edit Constraints with
Constraint Editor > Edit Timing Verifications Constraints).
The Constraints Editor shows the clock constraint at 250 MHz you entered earlier.

Figure 10-21. Clock Constraint Set to 250 MHz

2. Select the second row. Right-click and choose Edit Clock Constraint.
The Edit Clock Constraint dialog box appears.

3. Change the clock constraint from 250 MHz to 800 MHz, and then click the green check mark to
continue.

4. Click Open SmartTime > Open Interactively.
5. Choose Maximum Delay Analysis View to view the max delay analysis.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-29D74514-C048-43A6-A026-95300C69D319&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Changing%20Constraints%20and%20Observing%20Results%E2%80%9432-Bit%20Shift%20Register%20Example
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6. In the Maximum Delay Analysis window, expand my_clk.
7. Click Register to Register to observe the timing information. The slacks decrease after you

increase the frequency. You may see the slacks go negative, which indicates Timing Violations.
Negative slacks are shown in red.
Note: The actual timing numbers you see may be slightly different.

Figure 10-22. Maximum Delay Analysis After Setting Clock Constraint to 800 MHz

8. Close SmartTime. When prompted to save changes, click No.

10.2. Tutorial 2—False Path Constraints  (Ask a Question)

This section describes how to enter false path constraints in SmartTime. Import an RTL source
file from the following design. After routing the design, you analyze the timing, set false path
constraints, and observe the maximum operating frequency in the SmartTime Timing Analysis
window.

Figure 10-23. Example Design with False Paths

10.2.1. Set Up Your False Path Example Design Project  (Ask a Question)

To set up your false path example design project:

1. Open Libero.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-CC97B607-42A8-4AB3-B39A-CCAA1F5FB031&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Tutorial%202%E2%80%94False%20Path%20Constraints
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-BF3B2812-0AD4-49B8-87B2-5CB478C15A5B&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Set%20Up%20Your%20False%20Path%20Example%20Design%20Project
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2. From the Project menu, choose New Project to create a new project.
3. Name the project false_path and set the project location according to your preferences.

4. Click Next.
5. Enter the following values for your Device Selection settings:

• Family: SmartFusion 2
• Die: M2S050
• Package: 484 FBGA
• Speed: STD
• Die Voltage: 1.2 V
• Range: COM

6. Click Finish to create the new project.

10.2.2. Import the false_path Verilog File and Add Constraints  (Ask a Question)

For this tutorial, you import the false_path.v Verilog source file into your design, and then run Libero
SoC.

To import the Verilog source file:

1. From the File menu, choose Import > HDL Source Files.
2. Browse to the location of the false_path.v you saved and select it. Click Open to import the file.
3. Verify that the file appears in Design Hierarchy.
4. In the Design Flow window, double-click Synthesize to run synthesis.

A green check mark appears when the Synthesis step completes successfully.
5. Expand Edit Constraints.
6. Right-click Timing Constraints and choose Open Interactively.
7. Double-click Manage Constraints.
8. Select the Timing tab.
9. Expand the Edit with Constraint Editor sub-menu, and select Edit Place and Route

Constraints.
The Constraints Editor appears.

10. Double-click Requirements: Clock.
The Create Clock Constraint dialog box appears.

11. Double click the Browse button for Clock Source, select CLK, and assign it a name (for example,
clk).

12. Set the frequency to 100 MHz.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E267C989-C656-4CA0-ACCA-0E9CF536E695&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Import%20the%20false_path%20Verilog%20File%20and%20Add%20Constraints
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Figure 10-24. Clock Constraint of 100 MHz

13. Click OK to return to the Constraints Editor and observe that the clock information has been
filled in, as shown in the following figure.

Figure 10-25. Clock Constraint of 100 MHz in false_path Design

14. Save your changes (File > Save) and close the Constraints Editor (File > Close).
15. In the Constraint Manager, check the check boxes under Place and Route and Timing

Verification to associate the constraint file to both tools. The constraint file is used for both
Place and Route and Timing verification.

10.2.3. Place and Route Your FALSE_PATH Design  (Ask a Question)

To run Place and Route on false_path design:

1. In Libero SoC, right-click Place and Route and choose Configure Options.
The Layout Options dialog box appears.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-58B9873C-4C6D-4FDA-82C6-DDBF2B8B4181&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Place%20and%20Route%20Your%20FALSE_PATH%20Design
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Figure 10-26. Layout Options Dialog Box

2. Click the check box to enable Timing-Driven layout and leave all other values unchecked.
3. Click OK to close the Layout Options dialog box.
4. Right-click Place and Route and choose Run.

A green check mark appears next to Place and Route in the Design Flow window when Place
and Route completes successfully.
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Figure 10-27. Synthesize and Place and Route Successful Completion

10.2.4. Timing Analysis—Maximum Clock Frequency  (Ask a Question)

The SmartTime Maximum Delay Analysis View displays the design maximum operating frequency
and lists any setup violations.

To perform maximum delay analysis:

1. Expand Verify Post Layout Implementation.
2. Right-click Open SmartTime and choose Open Interactively to open SmartTime.

The Maximum Delay Analysis View appears. The Maximum Delay Analysis View summarizes
design performance and indicates that the design will operate at a maximum frequency of
442.48 MHz.
Note: You may see a slightly different maximum frequency with a different version of Libero
SoC.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D47B3511-B30F-4D80-8629-95269D321B59&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Analysis%E2%80%94Maximum%20Clock%20Frequency
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Figure 10-28. Maximum Delay Analysis Summary

3. Expand clk to expand the display and show the Register to Register path sets.
4. Select Register to Register to display the register-to-register paths. Notice that the slack values

are positive.

Figure 10-29. Expanded Path

5. Double-click to select and expand the row in the path list with the path is from the CLK pin of
flip-flop D0_reg to the D input of flip flop Q_reg. Note that the path goes through the S input of
multiplexer un1_MUX2.
Looking at the code in false_path.v, you can see on lines 51 and 52, that D0_reg and D)_inv_reg
are always the inverse of each other in "operational" mode (except when RST is active). Line 56
says that XOR2 is the XOR of these two signals, and hence always 1 (except when RST is active).
Line 59 says that XOR2 is the select of MUX2.
We might reasonably decide that we are not interested in the reset mode delay for this design;
therefore, this path is a false path for our timing analysis purposes.
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Figure 10-30. Analyzing the False Paths

Similar analysis shows that the path from D0_inv_reg:CLK to Q_reg:D shares exactly the same
false-path characteristic. Disable both paths.

6. Restart the Libero Constraints Editor. The Constraints Editor must be running to use SmartTime’s
back-annotation feature. Go to the Constraint Manager tab, then go to the Timing sub-tab, pull
down Edit with Constraint Editor, and choose Edit Timing Verification Constraints.

7. Leave this running and return to SmartTime.
8. From the Tools menu, select Max Delay Analysis.
9. To set the path from D0_inv_reg:CLK to Q_reg :D as false, select the row containing this path in

the Register to Register path set, right-click and choose Add False Path Constraint.
The Set False Path Constraint dialog box appears. It might pop behind the current dialog box, so
check other Constraint Manager windows.

Figure 10-31. Right-Clicking Add False Path Constraint

10. Click OK to close the Set False Path Constraint dialog box.
11. In the Constraints Editor window, check for an entry below Exceptions > False Path.
12. Return to the SmartTime window and repeat for the D0_reg:CLK -> Q_reg:D path.
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13. Because we are interested only in timing analysis through the MUX when select = 1, we can
ignore the MUX "0" path from D1_reg:D through the AND2. We make this a false path. At this
point the Constraints Editor should now look as follows. Save the file and exit the Constraints
Editor and SmartTime.

Figure 10-32. False Path Constraints in the SmartTime Constraint Editor

Place and Route is now invalidated and must be re-run before we can perform timing analysis again.
This is because we changed the constraint file we are using for both Place and Route and for Timing
Analysis. We can use different constraint files, in which case we would not need to re-run Place and
Route.
14. Right-click Open SmartTime and choose Update and Open Interactively.

You will see that Place and Route is run automatically before SmartTime is restarted.
15. View the summary in the Maximum Delay Analysis View (Tools > Max Delay Analysis).

SmartTime now reports the maximum operating frequency as 586.17 MHz, as shown in the
following figure.
Note: The maximum operating frequency may vary slightly with a different version of the Libero
software.
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Figure 10-33. Maximum Delay Analysis View—Summary

16. Select the Register to Register set for my_clk. Observe that only one path is visible, from D2_reg:
CLK to Q_reg:D. This is the only path that propagates a signal, as shown in the following figure.

Figure 10-34. Maximum Delay Analysis View—Register to Register

17. Close SmartTime.
18. Close Libero SoC.

10.2.5. false_path.v  (Ask a Question)

//////////////////////////////////////////////////////////// 
Company: Microchip Corp
//
// File history:
// 0.1 Initial Version
//
// Description:
// Simple example design to demonstrate use of timing // constraints.
//
// Targeted device: Family::SmartFusion2; Die::M2S050;

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-A9A6AB2A-8945-4590-88B9-1273078F566E&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=false_path.v
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// Package::484 FBGA;
//
// Author: Joe X // //
//
////////////////////////////////////////////////////////////
module     false_path (D0, D1, D2, RST, CLK, Q); input D0;
input      D1;
input      D2;
input      RST;
input      CLK;
output     Q;

reg        D0_reg;
reg        D0_inv_reg;
reg        D1_reg;
reg        D2_reg;

reg        Q_reg;

wire       XOR2          /*synthesis syn_keep=1*/; 
wire       AND2          /*synthesis syn_keep=1*/; 
wire       OR2           /*synthesis syn_keep=1*/; 
wire       MUX2          /*synthesis syn_keep=1*/; 
wire       NOT1          /*synthesis syn_keep=1*/; 
wire       NOT2          /*synthesis syn_keep=1*/;

assign Q = Q_reg /*synthesis syn_keep=1*/; 

always @(posedge CLK or posedge RST)

begin
          if (RST)
          begin
              D0_reg         <= 1'b0;
              D0_inv_reg     <= 1'b0;
          end
          else
          begin
              D0_reg         <= D0;
              D0_inv_reg     <= ~D0;
          end
end
          assign XOR2 = D0_reg ^ D0_inv_reg; 
          assign OR2 = D0_inv_reg || D1_reg; 
          assign AND2 = OR2 && D2_reg;
          assign MUX2 = (XOR2) ? (D2_reg) : (AND2);

          always @(posedge CLK) 
          begin
              D1_reg     <= D1;
              D2_reg     <= D2;

              Q_reg <= NOT2;
          end

          not u1 (NOT1, MUX2); 
          not u2 (NOT2, NOT1);

          endmodule
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11. SmartTime Dialog Boxes  (Ask a Question)

The following sections describe the SmartTime dialog boxes.

11.1. Add Path Analysis Set Dialog Box  (Ask a Question)

Use the Add Path Analysis Set dialog box to specify a custom path analysis set.

To open the Add Path Analysis Set dialog box from the SmartTime Timing Analyzer, choose any path
and right-click to select Add Set.

Note: The Analysis menu is available only in Maximum or Minimum Delay Analysis view.

Figure 11-1. Add Path Analysis Set Dialog Box

11.1.1. Name  (Ask a Question)

Enter the name of your path set.

11.1.2. Trace from  (Ask a Question)

Select whether you want to trace connected pins from Source to sink or from Sink to source. By
default, the pins are traced Source to sink.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F96D2B4E-7DDD-4507-8621-C49A84F55C81&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=SmartTime%20Dialog%20Boxes
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-156D36C0-7891-413E-9856-36C3E73AB8F2&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Add%20Path%20Analysis%20Set%20Dialog%20Box
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-CA14CB72-4784-4D42-8DC0-C420D92CC9AE&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Name
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-016ABF92-CA40-4870-8642-AADE82E846D8&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Trace%20from


 Libero SoC v2025.2
SmartTime Dialog Boxes

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 81

11.1.3. Source Pins  (Ask a Question)

Displays a list of available and valid source pins. You can select multiple pins. To select all source
pins, click the Select All button below the Source Pins list.

11.1.4. Select All  (Ask a Question)

Selects all the pins in the Source Pins list to include in the path analysis set.

11.1.5. Filter Source Pins  (Ask a Question)

Allows you to specify the source Pin Type and the Filter. The default pin type is Registers by pin
name. You can specify any string value for the Filter. If you change the pin type, the Source Pins
shows the updated list of available source pins.

11.1.6. Sink Pins  (Ask a Question)

Displays list of available and valid pins. You can select multiple pins. To select all source pins, click
the Select All button below the Sink Pins list.

11.1.7. Select All  (Ask a Question)

Selects all the pins in the Sink Pins list to include in the path analysis set.

11.1.8. Filter Sink Pins  (Ask a Question)

Allows you to specify the sink Pin Type and the Filter. The default pin type is Registers (by pin).
You can specify any string value for the Filter. If you change the pin type, the Sink Pins shows the
updated list of available sink pins.

11.2. Analysis Set Properties Dialog Box  (Ask a Question)

Use the Analysis Set Properties dialog box to view information about a user-created set.

To open the Analysis Set Properties dialog box from the Timing Analysis View, right-click a user-
created set in the Domain Browser, and then choose Properties from the shortcut menu.

Figure 11-2. Analysis Set Properties Dialog Box

11.2.1. Name  (Ask a Question)

Specifies the name of the user-created path set.

11.2.2. Parent Set  (Ask a Question)

Specifies the name of the parent path set to which the user-created path set belongs.

11.2.3. Creation Filter  (Ask a Question)

Specifies a list of source pins in the user-created path set.
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11.2.4. To  (Ask a Question)

Specifies a list of sink pins in the user-created path set.

11.3. Edit Filter Set Dialog Box  (Ask a Question)

Use the Edit Filter Set dialog box to specify a filter.

To open the Edit Filter Set dialog box from the SmartTime Max/Min Delay Analysis view, right-click a
filter set in the clock domain browser, and then choose Edit Set from the shortcut menu.

Figure 11-3. Edit Path Analysis Set Dialog Box

11.3.1. Name  (Ask a Question)

Specifies the name of the path you want to edit.

11.3.2. Creation filter  (Ask a Question)

Source Pins: Displays a list of source pins in the user-created path set.

Sink Pins: Displays a list of sink pins in the user-created path set.

11.4. Customize Analysis View Dialog Box  (Ask a Question)

Use the Customize Analysis View dialog box to customize the timing analysis grid.

To open the Customize Analysis View dialog box from the SmartTime Max/Min Delay Analysis View,
click the Customize table button (circled in red in the following figure) in the Max/Min Delay
Analysis View. The Customize Paths List Table dialog box appears.
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Figure 11-4. Customize Table Button

Figure 11-5. Customize Paths List Dialog Box

11.4.1. Available Fields  (Ask a Question)

Displays a list of all the available fields in the timing analysis grid.

11.4.2. Show These Fields in This Order  (Ask a Question)

Shows the list of fields you want to see in the timing analysis grid. Use Add or Remove to move
selected items from Available fields to Show these fields in this order or vice versa. You can
change the order in which these fields are displayed by using Move Up or Move Down.

11.4.3. Restore Defaults  (Ask a Question)

Resets all the options in the General panel to their default values.

11.5. Manage Clock Domains Dialog Box  (Ask a Question)

Use the Manage Clock Domains dialog box to specify the clock pins you want to see in the Expanded
Path view.
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To open the Manage Clock Domain dialog box from the SmartTime Max/Min Delay Analysis view,

click the icon.

Figure 11-6. Manage Clock Domains Dialog Box

11.5.1. Available Clock Domains  (Ask a Question)

Displays alphanumerically sorted list of available clock pins. The first clock pin is selected by default.

11.5.2. Show the Clock Domains in This Order  (Ask a Question)

Shows the clock pins you want to see in the Expanded Path view. Use Add or Remove to move
selected items from Available clock domains to Show the clock domains in this order or vice
versa. You can change the order in which these clock pins are displayed by using Move Up or Move
Down.

11.5.3. New Clock  (Ask a Question)

Allows you to add a non-explicit clock domain. Clicking this option opens the Choose the Clock
Source Pin dialog box, where you can select the clock source pin.

11.6. Set False Path Constraint Dialog Box  (Ask a Question)

Use the Set False Path Constraint dialog box to define specific timing paths as being false.

This constraint removes timing requirements on these false paths so that they are not considered
during the timing analysis. The path starting points are the input ports or register clock pins and
path ending points are the register data pins or output ports. This constraint disables setup and
hold checking for the specified paths.

Note: The false path information always takes precedence over multiple cycle path information and
overrides maximum delay constraints.

To open the Set False Path Constraint dialog box from the SmartTime Constraints Editor, choose
Constraints > Exceptions False Path > Add False Path Constraint.
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Figure 11-7. Set False Path Constraint Dialog Box

11.6.1. From  (Ask a Question)

Specifies the starting points for false path. A valid timing starting point is a clock, a primary input, an
input port, or a clock pin of a sequential cell.

11.6.2. Through  (Ask a Question)

Specifies a list of pins, ports, cells, or nets through which the disabled paths must pass.

11.6.3. To  (Ask a Question)

Specifies the ending points for false path. A valid timing ending point is a clock, a primary output, an
input port, or a data pin of a sequential cell.

11.6.4. Comment  (Ask a Question)

Allows you to provide comments for this constraint.

11.7. SmartTime Options Dialog Box  (Ask a Question)

Use the SmartTime Options dialog box to specify the SmartTime options to perform timing analysis.
This interface includes the following categories:

• General
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• Analysis
• Advanced

To open the SmartTime Options dialog box from the SmartTime tool, choose Tools > Options.

Figure 11-8. SmartTime Options—General Dialog Box for SmartFusion®  2, IGLOO®  2, and RTG4®

Figure 11-9. SmartTime Options—General Dialog Box for PolarFire®
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11.7.1. Operating Conditions  (Ask a Question)

Allows you to perform maximum or minimum delay analysis based on the Best, Typical, or Worst
case. By default, maximum delay analysis is based on WORST case and minimum delay analysis is
based on BEST case.

11.7.2. Clock Domains  (Ask a Question)

• Include inter-clock domains in calculations for timing analysis: Allows you to specify whether
SmartTime must use inter-clock domains in calculations for timing analysis. By default, this
option is checked.

• Enable recovery and removal checks: Allows SmartTime to check removal and recovery time
on asynchronous signals. Additional sets are created in each clock domain in Analysis View to
report the corresponding paths.

11.7.3. Restore Defaults  (Ask a Question)

Resets all the options in the General panel to their default values.

11.7.4. Analysis  (Ask a Question)

The following figure shows the SmartTime Options—Analysis View dialog box.

Figure 11-10. SmartTime Options—Analysis View Dialog Box

11.7.5. Display of Paths  (Ask a Question)

Limits the number of paths shown in a path set for timing analysis. The default value is 100. You
must specify a number greater than 1.

11.7.5.1. Filter the Paths by Slack Value  (Ask a Question)

Specifies the slack range between minimum slack and maximum slack. This option is unchecked by
default.

11.7.6. Show Clock Network Details in Expanded Path  (Ask a Question)

Displays the clock network details as well as the data path details in the Expanded Path views.
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https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E54F6865-F624-400D-8D50-359F647D41B0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Filter%20the%20Paths%20by%20Slack%20Value
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4D1275B6-8E12-4D21-A9DC-F0423089D317&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Show%20Clock%20Network%20Details%20in%20Expanded%20Path


 Libero SoC v2025.2
SmartTime Dialog Boxes

 User Guide
© 2025 Microchip Technology Inc. and its subsidiaries

DS50003087N - 88

Limit the number of parallel paths in expanded path to: For each expanded path, specify the
maximum number of parallel paths that SmartTime displays. The default number of parallel paths is
1.

11.7.7. Restore Defaults  (Ask a Question)

Resets all the options in the Analysis View panel to their default values.

11.7.8. Advanced Dialog Box  (Ask a Question)

The following figure shows the SmartTime Options—Advanced dialog box.

Figure 11-11. SmartTime Options—Advanced Dialog Box

11.7.9. Special Situations  (Ask a Question)

Allows you to specify whether you need to use loopback in bi-directional buffers (bibufs) and/or
break paths at asynchronous pins.

11.7.10. Scenarios  (Ask a Question)

Allows you to select the scenario to use for timing analysis and for timing-driven place-and-route.

11.7.11. Restore Defaults  (Ask a Question)

Resets all the options in the Analysis View panel to their default values.

11.8. Create Filter Set Dialog Box  (Ask a Question)

Use the Create Filter Set dialog box to specify a filter.

To open the Create Filter Set dialog box from the SmartTime Timing Analyzer, select a path, and click
the Store Filter button in the Analysis View Filter.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1AAC4741-41C4-4A05-9D49-F0A80FFF56AE&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F890FE4A-D702-4224-BA0C-4AE5CAE348A4&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Advanced%20Dialog%20Box
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-50A46802-FDD4-4044-AE97-77BBB0D397EF&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Special%20Situations
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E451EA20-CB19-41FA-AA09-D98488CF5446&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Scenarios
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-B5807E83-887F-431C-89BB-57B40D13BE50&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D820CD69-05C6-48F8-B29E-7A0C454A7100&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Create%20Filter%20Set%20Dialog%20Box
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Figure 11-12. Create Filter Set Dialog Box

11.8.1. Name  (Ask a Question)

Specifies the name of the filtered set.

11.9. Timing Bottleneck Analysis Options Dialog Box  (Ask a Question)

Use the Timing Bottleneck Analysis Options dialog box to customize the Timing Bottleneck Report.
You can set report options for the following categories:

• General pane
• Bottleneck pane
• Sets pane

To open the Timing Bottleneck Analysis Options dialog box from the SmartTime tool, choose Tools >
Bottleneck Analysis.

11.9.1. General Pane  (Ask a Question)

The following figure shows the Timing Bottleneck Options—General Pane dialog box.

Figure 11-13. Timing Bottleneck Options—General Pane Dialog Box

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-00CDC4D2-523E-42BE-9F92-BF35C8C5FB3F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Name
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-05ED0374-C577-4F82-AAAB-331A31619D55&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Bottleneck%20Analysis%20Options%20Dialog%20Box
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-A4E52A06-C74D-4AEC-9C9F-F887C8863232&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=General%20Pane
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11.9.2. Slack  (Ask a Question)

Allows you to specify whether the reported paths is filtered by threshold and, if so, what maximum
slack to report. By default, the paths are filtered by slack and the slack threshold is 0.

11.9.3. Restore Defaults  (Ask a Question)

Resets all the options in the General pane to their default values.

11.9.4. Bottleneck Pane  (Ask a Question)

The following figure shows the Timing Bottleneck Options—Bottleneck Pane dialog box.

Figure 11-14. Timing Bottleneck Options—Bottleneck Pane Dialog Box

11.9.5. Bottleneck Options  (Ask a Question)

Cost Type: Select the cost type that SmartTime will include in the Bottleneck Report. By default, path
count is selected. You can select one of the following two items from the drop-down list:

• Path Count: This cost type associates the severity of the bottleneck to the count of violating/
critical paths that traverse the instance. This is the default.

• Path Cost: This cost type associates the severity of the bottleneck to the sum of the timing
violations for the violating/critical paths that traverse the instance.

Limit the number of paths per section to: Specify the maximum number of paths per set type
that SmartTime will include per section in the report. The default maximum number of paths
reported is 100.

Limit the number of parallel paths per section to: For each expanded path, specify the maximum
number of parallel paths that SmartTime will include in the report. Only cells that lie on these
violating paths are reported. The default number of parallel paths is 1.

Limit the number of reported instances: Specify the maximum number of cells that SmartTime
will include per section in the report. The default number of cells is 10.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-03A1631F-432C-4118-9965-845A6F0BFEA3&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Slack
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-25935292-94B4-4F8A-B687-95132C9047DD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-B35A7AB4-2A21-4C02-970D-3505DC34F475&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Bottleneck%20Pane
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-81476622-683C-43F1-A8B4-AEFC800A4025&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Bottleneck%20Options
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11.9.6. Restore Defaults  (Ask a Question)

Resets all the options in the Bottleneck panel to their default values.

11.9.7. Sets Pane  (Ask a Question)

The Sets pane has four mutually exclusive options:

• Entire design
• Clock Domain
• Use existing user set
• Use Input to Output Set

Figure 11-15. Timing Bottleneck Report—Sets Pane Dialog Box

Entire design: Displays bottleneck information for the entire design.

Clock Domain: Displays bottleneck information for the selected clock domain. You can specify the
following options:

• Clock: Allows pruning based on a given clock domains. Only cells that lie on these violating paths
are reported.

• Type: This option can only be used with clock. The following table shows the acceptable values.

Table 11-1. Acceptable Type Values
Value Description

Register to Register Paths between registers in the design.

Asynchronous to Register Paths from asynchronous pins to registers.

Register to Asynchronous Paths from registers to asynchronous pins.

External Recovery The set of paths from inputs to asynchronous pins.

External Setup Paths from input ports to register.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-33FF98EE-6C7C-4A52-9C4C-2E0147E6E73C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-06E54525-4D4B-4251-8692-8A2ECAE8D05B&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Sets%20Pane
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Table 11-1. Acceptable Type Values (continued)
Value Description

Clock to Output Paths from registers to output ports.

Use existing user set: Displays bottleneck information for the existing user set selected. Only paths
that lie within the name set will be considered towards the Bottleneck Report.

Filter: Allows you to filter the Bottleneck Report by the following options:

• From: Reports only cells that lie on violating paths that start at locations specified by this option.
• To: Reports only cells that lie on violating paths that end at locations specified by this option.

Filter defaults to all outputs.

11.9.8. Restore Defaults  (Ask a Question)

Resets all the options in the Paths panel to their default values.

11.10. Timing Datasheet Report Options Dialog Box  (Ask a Question)

Use the Timing Datasheet Report Options dialog box to select the output format for the Timing
Datasheet Report.

To open the Timing Datasheet Report Options dialog box from the SmartTime Max/Min Delay
Analysis view, choose Tools > Reports > Datasheet.

You can generate your report in one of two formats:
• Plain Text: Saves your report to disk in plain ASCII text format.
• Comma Separated Values: Saves your report to disk in comma-separated value format (.CSV)

format, which you can import into a spreadsheet

Note:  This Datasheet Report feature is not supported for PolarFire.

Figure 11-16. Report Options Dialog Box

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-5329CE6D-33B6-4C2F-B906-63937FF4F695&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-6F4BB0EE-AD89-4EBC-BBB6-800B7E5BA7D6&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Datasheet%20Report%20Options%20Dialog%20Box
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11.11. Timing Report Options Dialog Box  (Ask a Question)

Use the Timing Report Options dialog box to customize the Timing Report. You can set report
options for the following categories:

• General
• Paths
• Sets
• Clock Domains

To open the Timing Report Options dialog box from the SmartTime Max/Min Delay Analysis View,
choose Tools > Reports > Timer.

11.11.1. General  (Ask a Question)

The following figure shows the Timing Report Options—General dialog box.

Figure 11-17. Timing Report Options—General Dialog Box

11.11.1.1. Format  (Ask a Question)

Specifies whether the report exports as a Comma Separated Value (CSV) file or a plain text file. By
default, the Plain Text option is selected.

11.11.1.2. Summary  (Ask a Question)

Specifies whether the summary section is included in the report. By default, this option is selected.

11.11.1.3. Analysis  (Ask a Question)

Specifies the type of analysis to be included in the Timing Report is a Maximum Delay Analysis
Report or a Minimum Delay Analysis Report. By default, the Maximum Delay Analysis Report is
included in the Timing Report.

11.11.1.4. Slack  (Ask a Question)

Allows you to specify whether the reported path is filtered by threshold and, if so, what maximum
slack to report. By default, the paths are not filtered by slack.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-29A2149F-C54F-4D59-B99E-CCC19A108FF0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Report%20Options%20Dialog%20Box
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-F3B9AFC7-7B7B-4255-9757-2D5A0DB6BEEF&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=General
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-91D9B9FA-5F2D-45D2-A760-DB52932A87F5&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Format
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-71AA6DE8-8E3B-4F44-A9C3-6FAA7E3C53C8&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Summary
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-62000D1C-D5A1-4462-AF9C-1ADD4616E142&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Analysis
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1E18665A-E785-434E-B80C-274B6A17CF4F&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Slack
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11.11.2. Paths  (Ask a Question)

The following figure shows the Timing Report Options—Paths dialog box.

Figure 11-18. Timing Report Options—Paths Dialog Box

11.11.3. Display of Paths  (Ask a Question)

Include detailed path information in this report: Check this box to include the detailed path
information in the Timing Report.

Limit the number of reported paths per section to: Specify the maximum number of paths that
SmartTime will include per section in the report.

Limit the number of expanded paths per section to: Specify the maximum number of expanded
paths that SmartTime will include per section in the report.

Limit the number of parallel paths in expanded path to: For each expanded path, specify the
maximum number of parallel paths that SmartTime will include in the report. The default number of
parallel paths is 1.

11.11.4. Sets  (Ask a Question)

The following figure shows the Timing Report Options—Sets dialog box.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-DBD55C72-6E79-4614-8535-0CC61FD0A9D4&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Paths
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-FD61BB96-C8D2-4D62-8591-E75AFD90D065&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Display%20of%20Paths
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4A46CCB9-E8C6-4C4C-A235-8773DD4517B1&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Sets
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Figure 11-19. Timing Report Options—Sets Dialog Box

11.11.4.1. Display of Sets  (Ask a Question)

Specifies whether user sets are included in the Timing Report.

User sets are either filters you created and stored on the default paths sets (Register to Register,
Inputs to Register, and so on) or Pin-to-Pin user sets. By default, the paths for these sets are not
reported.

You can also specify whether the Inputs to Output sets are included in the report. By default, the
Input to Output sets are reported.

11.11.5. Clock Domains  (Ask a Question)

The following figure shows the Timing Report Options—Clock Domains dialog box.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-70EB3049-DC4F-47DA-8A05-F33D634534A0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Display%20of%20Sets
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-B8ACE9D1-5014-41C1-B095-C90D41B78559&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Clock%20Domains
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Figure 11-20. Timing Report Options—Clock Domains Dialog Box

11.11.5.1. Display of Clock Domains  (Ask a Question)

Allows you to specify the clock domains included in the report. By default, the current clock domains
used by the timing engine is reported.

11.11.5.2. Include Clock Domains  (Ask a Question)

Allows you to include or exclude clock domains in the report. Click the check box to include clock
domains.

11.11.5.3. Limit Reporting on Clock Domains to Specified Domains  (Ask a Question)

Allows you to include clock domain names in the box, or include additional clock domain names
using Select Domains.

11.12. Timing Violations Report Options Dialog Box  (Ask a Question)

Use the Timing Violations Report Options dialog box to customize the Timing Violation Report. You
can set report violation options for the following categories:

• General
• Paths

To open the Timing Report Options dialog box from the SmartTime tool, choose Tools > Reports >
Timing Violations.

11.12.1. General  (Ask a Question)

The following figure shows the Timing Violations Report Options—General dialog box.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-42559F70-D71E-4D82-8F6F-93CD6B2F9E9C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Display%20of%20Clock%20Domains
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-BDFFC4A8-5CDF-4207-8D68-F6CD0A5C5DCC&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Include%20Clock%20Domains
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-08B856E0-AD6E-459D-8D11-CA4F193957C6&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Limit%20Reporting%20on%20Clock%20Domains%20to%20Specified%20Domains
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-892D2E3C-BC08-4D52-8468-95678F41CD25&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Timing%20Violations%20Report%20Options%20Dialog%20Box
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-4532722F-6547-4863-A316-40794222CF30&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=General
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Figure 11-21. Timing Violations Report Options—General Dialog Box

11.12.1.1. Format  (Ask a Question)

Specifies whether the report exports as a Comma Separated Value (CSV) file or a plain text file. By
default, the Plain Text option is selected.

11.12.1.2. Analysis  (Ask a Question)

Allows you to specify what type of analysis is reported in the report. By default, the report includes
Maximum Delay Analysis.

11.12.1.3. Slack  (Ask a Question)

Allows you to specify whether the reported paths is filtered by threshold and, if so, what maximum
slack to report. By default, the paths are filtered by slack and the slack threshold is 0.

11.12.1.4. Restore Defaults  (Ask a Question)

Resets all the options in the General panel to their default values.

11.12.2. Paths  (Ask a Question)

The following figure shows the Timing Violations Report Options—Paths dialog box.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-FF3342D5-2D1D-4D5F-9443-DAA81619DA5B&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Format
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-6DAD357F-9C39-4005-AAF1-FF6B26CFA52A&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Analysis
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-1EC8DD22-D9A6-4A53-8D9D-51A76B858163&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Slack
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-84CFD867-4C37-4BAA-A4DC-01A08C90B8AD&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-88492E88-D2B8-4F88-88FF-AD68D7196D2C&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Paths
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Figure 11-22. Timing Violations Report Options—Paths Dialog Box

11.12.2.1. Display of Paths  (Ask a Question)

Limit the number of reported paths: Check this box to limit the number of paths in the report. By
default, the number of paths is limited.

Limit the number of paths per section to: Specify the maximum number of paths that SmartTime
will include per section in the report. The default maximum number of paths reported is 100.

Limit the number of expanded paths per section to: Specify the maximum number of expanded
paths that SmartTime will include per section in the report. The default number of expanded paths
is 0.

Limit the number of parallel paths in expanded path to: For each expanded path, specify the
maximum number of parallel paths that SmartTime will include in the report. The default number of
parallel paths is 1.

11.12.2.2. Restore Defaults  (Ask a Question)

Resets all the options in the Paths panel to their default values.

11.13. Data Change History—SmartTime  (Ask a Question)

The data change history lists features, enhancements, and bug fixes for the current software release
that may impact timing data of the current design.

To generate a data change history, choose Data Change History from the Help menu to display a
data change history in text format.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-75D4D691-4BDF-44B1-B317-DF26FFAE04C3&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Display%20of%20Paths
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-D410C4A1-7D5C-4CC5-8F86-05A155D8572D&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Restore%20Defaults
https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-9C556D94-F0B2-4650-A3C0-7C00422E84B0&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Data%20Change%20History%E2%80%94SmartTime
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Figure 11-23. SmartTime Data Change History Report
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12. Tcl Commands  (Ask a Question)

For details about the Tcl commands supported by SmartTime, see the Tcl Commands Reference
Guide.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-AB5F5CF9-8D42-47D3-BDC3-1E8CDEA45C65&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Tcl%20Commands
http://coredocs.s3.amazonaws.com/Libero/2025_1/Tool/libero_soc_tcl_cmd_ref_ug.pdf
http://coredocs.s3.amazonaws.com/Libero/2025_1/Tool/libero_soc_tcl_cmd_ref_ug.pdf
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13. Glossary  (Ask a Question)

The following glossary defines terms in this user guide.

Table 13-1. Glossary
Term Definition

Arrival time Actual time in nanoseconds when data arrives at a sink pin
when considering the propagation delays across the path.

Asynchronous Two signals that are not related to each other. Signals not
related to the clock are usually asynchronous.

Capture edge The clock edge that triggers the capture of data at the end
point of a path.

Clock A periodic signal that captures data into sequential elements.

Critical path A path with the maximum delay between a starting point
and an end point. In the presence of a clock constraint, the
worst critical path between registers in this clock domain is
the path with the worst slack.

Data timing analysis The standard method for verifying design functionality and
performance. Both pre-layout and post-layout timing analysis
can be performed via the SDF interface.

Exception See timing exception.

Explicit clock Clock sources that can be traced back unambiguously from
the clock pin of the registers they deserve, including the
output of a DLL or PLL.

Filter A set of limitations applied to object names in timing analysis
to generate target specific sets.

Launch edge The clock edge that triggers the release of data from a
starting point to be captured by another clock edge at an
end point.

Minimum period Timing characteristic of a path between two registers. It
indicates how fast the clock runs when this path is the
most critical one. The minimum period value takes into
consideration both the skew and the setup on the receiving
register.

Parallel paths Paths that run in parallel between a given source and sink
pair.

Path A sequence of elements in the design that identifies a logical
flow starting at a source pin and ending at a sink pin.

Path details An expansion of the path that shows all the nets and cells
between the source pin and the sink pin.

Path set A collection of paths.

Paths list Same as path set.

Post-layout The state of the design after you run Layout. In post-layout,
the placement and routing information are available for the
whole design.

Potential clock Pins or ports connected to the clock pins of sequential
elements that the STA tool cannot determine whether they
are is enabled sources or clock sources. This type of clock is
generally associated with the use of gated clocks.

Pre-layout The state of the design before you run Layout. In pre-layout,
the placement and routing information are not available.

Recovery time The amount of time before the active clock edge when the
de-activation of asynchronous signals is not allowed.

Removal time The amount of time after the active clock edge when the
de-activation of asynchronous signals is not allowed.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-2828B133-C6FD-448F-A255-5EA58554C211&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Glossary
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Table 13-1. Glossary (continued)
Term Definition

Required time The time when data must be at a sink pin to avoid being in
violation.

Requirement See timing requirement.

Scenario (timing constraints scenario) Set of timing constraints defined by the user.

Setup time The time in nanoseconds relative to a clock edge during
which the data at the input to a sequential element must
remain stable.

Sink pin The pin located at the end of the timing path. This pin is
usually the one where arrival time and required time are
evaluated for path violation.

Skew The difference between the clock insertion delay to the clock
pin of a sink register and the insertion delay to the clock pin
of a source register.

Slack The difference between the arrival time and the required
time at a specific pin, generally at the data pin of a sequential
component.

Slew rate The time needed for a signal to transition from one logic level
to another.

Source pin The pin located at the beginning of a timing path.

STA See static timing analysis.

Standard delay format (SDF) A standard file format used to store design data suited for
back-annotation.

Static timing analysis An efficient technique to identify timing violations in a design
and to ensure that all timing requirements are met. It is
well suited for traditional synchronous designs. The main
advantages are that it does not require input vectors, and
it exclusively covers all possible paths in the design in a
relatively short run-time.

Synopsys design constraint (SDC) A standard file format for timing constraints. SDC is a Tcl-
based format used by Synopsys tools to specify the design
intent, including the timing and area constraints for a design.
Micrchip SoC tools use a subset of the SDC format to capture
supported timing constraints. You can import or export an
SDC file from the Designer software. Any timing constraint
that you can enter using Designer tools, can also be specified
in an SDC file.

Timing constraint A requirement or limitation on the design to be satisfied
during the design implementation.

Timing exception An exception to a general requirement usually applied on a
subset of the objects on which the requirement is applied.

Timing requirement A constraint on the design usually determined by the
specifications at the system level.

Virtual clock A virtual clock is a clock with no source associated to it. It is
used to describe clocks outside the FPGA that have an impact
on the timing analysis inside the FPGA. For example, if the
I/Os are synchronous to an external clock.

Wire Load Model (WLM) A timing model used in pre-layout to estimate a net delay
based on the fan-out.
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14. Revision History  (Ask a Question)

The revision history describes the changes that were implemented in the document. The changes
are listed by revision, starting with the most current publication.

Table 14-1. Revision History
Revision Date Description

N 12/2025 This document is released with Libero SoC Design Suite v2025.2 without changes from v2025.1.

M 05/2025 The following is a summary of the changes made in this revision:
• In the section Generating a Clock Domain Crossing (CDC) Report, updated Figure 8-7 and the last row

in Table 8-7.

L 07/2024 The following is a summary of the changes made in this revision:
• Updated content in the Understanding Inter-Clock Domain Analysis section.

• Updated content in the Inter-clock Domain section.

• Updated content in the Clock Domains section.

K 02/2024 This document is released with Libero SoC Design Suite v2024.1 without changes from v2023.2.

J 08/2023 This document is released with Libero SoC Design Suite v2023.2 without changes from v2023.1.

H 04/2023 This document is released with Libero SoC Design Suite v2023.1 without changes from v2022.3.

G 12/2022 This document is released with Libero SoC Design Suite v2022.3 without changes from v2022.2.

F 08/2022 This document is released with Libero SoC Design Suite v2022.2 without changes from v2022.1.

E 04/2022 This document is released with Libero SoC Design Suite v2022.1 without changes from v2021.3.

D 12/2021 This document is released with Libero SoC Design Suite v2021.3 without changes from v2021.2.

C 08/2021 • Changed clk2 to clk1 in point 8 of Deactivating a Specific Inter-Clock Domain.

B 04/2021 • Generating a CDC Report: Added information related to cross probing, corner scenarios, and
updated notes.

A 11/2020 • Document converted to Microchip template. Initial Revision.

https://www.microchip.com/askaquestion?pub_guid=GUID-C9D871E5-9945-4F78-ACFB-FAD9E9698971&pub_lang=en-US&pub_ver=18&pub_type=User%20Guide&bu=fpga&tpc_guid=GUID-E7899F27-5083-4CCE-9CE5-DE78D02CD0FC&cover_title=SmartTime%20Static%20Timing%20Analyzer%20User%20Guide&tech_support_link=NA&revision_letter=N&source=PDF&title=Revision%20History
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Microchip FPGA Support
Microchip FPGA products group backs its products with various support services, including
Customer Service, Customer Technical Support Center, a website, and worldwide sales offices.
Customers are suggested to visit Microchip online resources prior to contacting support as it is
very likely that their queries have been already answered.

Contact Technical Support Center through the website at www.microchip.com/support. Mention the
FPGA Device Part number, select appropriate case category, and upload design files while creating a
technical support case.

Contact Customer Service for non-technical product support, such as product pricing, product
upgrades, update information, order status, and authorization.

• From North America, call 800.262.1060
• From the rest of the world, call 650.318.4460
• Fax, from anywhere in the world, 650.318.8044

Microchip Information
Trademarks
The “Microchip” name and logo, the “M” logo, and other names, logos, and brands are registered
and unregistered trademarks of Microchip Technology Incorporated or its affiliates and/or
subsidiaries in the United States and/or other countries (“Microchip Trademarks”). Information
regarding Microchip Trademarks can be found at https://www.microchip.com/en-us/about/legal-
information/microchip-trademarks.

ISBN: 979-8-3371-2456-8

Legal Notice
This publication and the information herein may be used only with Microchip products, including
to design, test, and integrate Microchip products with your application. Use of this information
in any other manner violates these terms. Information regarding device applications is provided
only for your convenience and may be superseded by updates. It is your responsibility to ensure
that your application meets with your specifications. Contact your local Microchip sales office for
additional support or, obtain additional support at www.microchip.com/en-us/support/design-help/
client-support-services.

THIS INFORMATION IS PROVIDED BY MICROCHIP “AS IS”. MICROCHIP MAKES NO REPRESENTATIONS
OR WARRANTIES OF ANY KIND WHETHER EXPRESS OR IMPLIED, WRITTEN OR ORAL, STATUTORY
OR OTHERWISE, RELATED TO THE INFORMATION INCLUDING BUT NOT LIMITED TO ANY IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY, AND FITNESS FOR A PARTICULAR
PURPOSE, OR WARRANTIES RELATED TO ITS CONDITION, QUALITY, OR PERFORMANCE.

IN NO EVENT WILL MICROCHIP BE LIABLE FOR ANY INDIRECT, SPECIAL, PUNITIVE, INCIDENTAL, OR
CONSEQUENTIAL LOSS, DAMAGE, COST, OR EXPENSE OF ANY KIND WHATSOEVER RELATED TO THE
INFORMATION OR ITS USE, HOWEVER CAUSED, EVEN IF MICROCHIP HAS BEEN ADVISED OF THE
POSSIBILITY OR THE DAMAGES ARE FORESEEABLE. TO THE FULLEST EXTENT ALLOWED BY LAW,
MICROCHIP’S TOTAL LIABILITY ON ALL CLAIMS IN ANY WAY RELATED TO THE INFORMATION OR
ITS USE WILL NOT EXCEED THE AMOUNT OF FEES, IF ANY, THAT YOU HAVE PAID DIRECTLY TO
MICROCHIP FOR THE INFORMATION.

Use of Microchip devices in life support and/or safety applications is entirely at the buyer’s risk,
and the buyer agrees to defend, indemnify and hold harmless Microchip from any and all damages,
claims, suits, or expenses resulting from such use. No licenses are conveyed, implicitly or otherwise,
under any Microchip intellectual property rights unless otherwise stated.

http://www.microchip.com/support
https://www.microchip.com/en-us/about/legal-information/microchip-trademarks
https://www.microchip.com/en-us/about/legal-information/microchip-trademarks
https://www.microchip.com/en-us/support/design-help/client-support-services
https://www.microchip.com/en-us/support/design-help/client-support-services
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Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip products:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner, within

operating specifications, and under normal conditions.
• Microchip values and aggressively protects its intellectual property rights. Attempts to breach the

code protection features of Microchip products are strictly prohibited and may violate the Digital
Millennium Copyright Act.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its
code. Code protection does not mean that we are guaranteeing the product is “unbreakable”.
Code protection is constantly evolving. Microchip is committed to continuously improving the
code protection features of our products.
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